WordPress.org

Support

Support » How-To and Troubleshooting » “Do you want to navigate away from this page” problem

“Do you want to navigate away from this page” problem

  • Since upgrading to 2.1, I’ve tried to write a test post to the blog. When I push “Publish”, I get the “Are you sure you want to navigate away from this page” window. The post appears, but it’s the title only. When I try to reedit the post and press “Save”, the same thing happens.

Viewing 15 replies - 1 through 15 (of 16 total)
  • My error console is showing this:

    Error: [Exception… “‘Permission denied to set property XULElement.selectedIndex' when calling method: [nsIAutoCompletePopup::selectedIndex]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "JS frame :: http://dev.throneworld.com/gemmillistan/wp-admin/post-new.php :: anonymous :: line 244" data: no]
    Source File: http://dev.throneworld.com/gemmillistan/wp-admin/post-new.php
    Line: 244

    foolswisdom

    @foolswisdom

    Moderator

    What browser? What version? On what OS?

    If you turn off Visual editor (in your profile) do you still encounter this issue?

    Tried in FF 2.0.01 and IE7 – same problem. In IE7 a Stack error is generated.

    Turning off the visual editor allows me to post. I still have the categories and links problem outlined here

    Same issue here – IE7.

    I get the problem with FF 2.0.

    I am wondering if the WordPress 2.0–>2.1 upgrade instructions were incorrect? I deleted all WordPress files and installed new ones, and that seems to have fixed my problems.

    I also have the “Are you sure you want to navigate away from this page” pop-up window problem.

    BUT, I also have the problem of not being able to create any new categories (an even bigger problem)!!!

    I think these 2 might be related, as I’ve seen them mentioned together before.

    I’m not doing an upgrade, but rather a complete NEW INSTALL of WP 2.1 via Fantastico (Lunarpages hosting). Using Win XP-SP2, MSIE 6 or FireFox. Have tried repeated deletes & full fresh installs, but always the same –> I can’t create any categories, and, get the “Are you sure you want… etc.” pop-up warning.

    Still *desperately* looking for a fix… Thanks!

    BTW, just tried WP 2.11 version, did not fix situation

    still cannot create any new categories (!!!)

    [now looking for alternatives, considering Expression Engine, Moveable Type]

    Have any of you tried deleting all files from your web server and reinstalling the WP files from scratch? What effect did that have?

    I have exactly the same problem but… I have two installations of 2.1 done at approximately the same time on different sites on the same isp and one has the problem and one doesn’t.

    Same browser (ie7) but there are some different plugins. Everything works well on both with the standard editor but the visual doesn’t work on one site and I get this error.

    novasource:

    YES, using Fantastico, I completely removed the WP install, then did a fresh new install for WP 2.1 and also WP 2.11 (I have no files, special plugins, etc. so I can do that)

    I am just doing the standard Fantastico install

    most admin panel functions seem to work (I haven’t tried them all)

    I constantly get the “are you sure you want to navigate away from this page” warning when I want to go anywhere which seems stange (not to mention irritating)

    BUT even more importantly, I cannot create any new categories (!!!)

    have noticed quite a few other people cannot create categories (and get the “are you sure…” warning in WP 2.X), but so far no one has a fix, other than possibly to install some 3rd party “category manager” plugin which “somehow just fixes it”, but that is hardly a proper fix

    any help hugely appreciated

    I’m having the same problem… When I first installed I can create “categories” BUT when I logged out and came back I wans’t able to create any new categories.. I get the annoying message of “are you sure you want to navigate…”

    I tried isntalling and unistalling WP a few times.. But it’s all the same…

    Any suggestions?

    Many thanks in advance!

    Same problem here. Can’t create new categories. I get “Are you sure you want to navigate…” message everywhere I go in WP admin.

    This is a serious problem that should be addressed by WordPress, I mean, can’t create categories? Might as well use blogger.

    WordPress is better than this.

    It turns out my problems were caused by using WPG2 2.01. I upgraded to WPG2 2.1, and they went away.

    Hi,

    same problem here. WP 2.1.3 and IE6.
    I created a page and when I click on the + to open the options for eg template the ‘navigate away’ msg comes up.

    Cu
    Martin

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘“Do you want to navigate away from this page” problem’ is closed to new replies.