Support » Plugin: List category posts » Do we need to change templates for 0.82

  • Resolved AndyHenderson

    (@andyhenderson)


    I see the template default.php is quite different to the previous one.

    Not least the main loop uses:

    while ( have_posts() )

    while the old one uses:

    foreach ($this->catlist->get_categories_posts() as $single)

    No problem switching to the new code out-of-hours but can we update the plugin before that? If not, the update notice could perhaps make it clearer this is a breaking change.

    Andy

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor zymeth25

    (@zymeth25)

    Hi

    The get_categories_posts() method is still in CatList so all your old templates should work without any changes. If not please let me know.

    It should not be a breaking change but if it is, feedback is appreciated.

    Thanks

    • This reply was modified 1 year, 6 months ago by zymeth25.
    Thread Starter AndyHenderson

    (@andyhenderson)

    Thanks for the fast response.

    I updated to 0.82 and everything still works OK.

    Thanks for a very useful plugin,

    Andy

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Do we need to change templates for 0.82’ is closed to new replies.