Support » Plugin: Favicon by RealFaviconGenerator » Does not work UPDATED:working now!

  • Installed just fine then it sent me to website to upload file. I uploaded it, the program looked like it was working. But nothing on my website, the plugin shows my graphic but my site has no files, and nothing shows in any browsers. I did the “Favicon checker” and it was a sea of red, no icons.
    I just uninstalled and reinstalled the plugin and tried again; this time uploading my graphic to the media library first, but got the same results.
    The HTML is generated, but no files are uploaded to my site.

    Update: Philippe Bernard has worked with me to get the plugin working. Just one last Issue to get Five (5) stars; and that is to get it in the root.

    For the readers out there: Yandex looks for favicon.ico in the root.
    Easy fix I just copied the favicon.ico file to the root myself

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author phbernard

    (@phbernard)

    I’m sorry you had troubles with the plugin.

    You say the files themselves were not setup? For example, in the HTML code, you might have seen something like
    <link rel="icon" type="image/png" href="/favicon-32x32.png" sizes="32x32">. So you accessed http://yourwebsite.com/favicon-32×32.png and you got a 404, is that right?

    Which web server are you using? Apache? Something else?

    1and1 web hosting linux based
    I was able from your website (http://realfavicongenerator.net/) able to create a manual instal version. I then ftp’d those file to the root to I get all green marks from your icon checker.

    WordPress v3.9.1

    Now have different issue not relating to you thoe, there server has cashed the icons, and only serves up the old ones. After seeing them work I changed to white letters.

    If there is something I can to to help you solve the issue of it not uploading let me know.

    Plugin Author phbernard

    (@phbernard)

    Regarding the plugin itself, it’s quite hard to reproduce this kind or issue because this is so dependent on the environment. 1and1 surely brings its own set of specific stuff. However, I may know who the culprit is. I have just released a new version (1.1.1) of the plugin that might fix the issue. I would be glad if you could give it another try and let me know if it works or not.

    Regarding the new/old icon issue you face after FTP upload may be due to a browser caching issue. If your browser knows your old icon, it may not load the new one. I advice you to use another browser (like one you already have on your PC but don’t use that often).

    I uninstalled and then installed the update, I also deleted the current set of icons from the root.
    This time the plugin did upload the icon set; but it did not put them in the root.
    It placed them here:
    href=”/wp-content/uploads/fbrfg/apple-touch-icon-60×60.png
    Some search engines like Yandex look for the favicon.ico in the root.

    And according to the icon checker from your site I now have an issue:
    Some PNG favicon(s) dimensions do not match the sizes attribute.

    Plugin Author phbernard

    (@phbernard)

    Not having the files in the root directory is the point of the fix: apparently, the environment provided by 1and1 prevents a plugin from manipulating URLs. So the plugin can only rely on a dedicated directory to host the pictures. However I didn’t realize that it was an issue to you :-/

    The error message from the checker in not normal. Could you post the URL of your site for review? If you don’t want to publish it here, you can also drop me an email: philippe@realfavicongenerator.net

    Plugin Author phbernard

    (@phbernard)

    Hi,

    There are news about this issue! The plugin puts the files in the root directory again… when it can do so. In fact, it places files in /wp-content/uploads/fbrfg as before and the HTML code always references them. But it uses the web server capabilities (when possible) to make the files appear in the root directory. In other words, in your HTML code, you will have:

    <link rel=”shortcut icon” href=”/blog/wp-content/uploads/fbrfg/favicon.ico”>

    But http://example.com/favicon.ico also works, so that Yandex and friends will find it, too.

    Note: unfortunately, in YOUR specific case, that won’t work. The rewrite API failed a few months ago, it still probably fails today. At least, the plugin is now able to take advantage of this feature whenever available.

    More about this here: https://wordpress.org/support/topic/choose-between-rewrite-api-and-dedicated-directory

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Does not work UPDATED:working now!’ is closed to new replies.