Support » Plugin: Asset CleanUp: Page Speed Booster » DO NOT UPDATE TO 1.3.6.1

  • Resolved not1_name

    (@not1_name)


    It adds rules on its own and breaks every page. I set about 17 rules, and after the update it was 117!
    To make things worse it can’t be switched to the test mode so that it can be fixed.
    Even uninstalling and re-installing the plugin leaves all these rules in place so there is no way to fix and uninstalling is the only way.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Gabe Livan

    (@gabelivan)

    @not1_name thanks for reporting a potential issue! When you’re saying is breaking every page, can you tell me more things about it? Also, were those 17 rules unload rules? The more you can tell me, the better! I switched the statable tag back to 1.3.6.0 as there was someone else reporting issues about it.

    Thread Starter not1_name

    (@not1_name)

    They were unload rules. Unfortunately, there is no way to check. If I install the plugin it breaks the site with no way for me to stop it. You should allow users to be able to completely uninstall the plugin without leaving files that corrupt any re-installs. If you allowed complete uninstalls, I could have at least started fresh.

    I’m trying to take an old version of a local site and will need to build all the rules again.

    Thread Starter not1_name

    (@not1_name)

    I see you have uploaded the previous version, but as you have files that are left on the system, when I install the last version of the plugin, I am still left with these bloody 117 unloads! Can you tell me how to get rid of the crap the last version left? With a few minutes left before an online promotion started, this is incredibly frustrating. Please allow users to fully uninstall.

    Plugin Author Gabe Livan

    (@gabelivan)

    @not1_name if you reverted to 1.3.6.0, you shouldn’t have any files left from 1.3.6.1. The only ones left are the cached CSS/JS from /wp-content/cache/asset-cleanup/, but they are inactive (if there were faulty ones) if you reverted back to 1.3.6.0. As for clearing all the rules, you can do that via “Tools” -> “Reset”. Don’t forget about the “Import & Export” feature if you have already used it.

    To make things worse it can’t be switched to the test mode so that it can be fixed.

    The “Test Mode” does activate on my end. Don’t you see the message “TEST MODE IS ON” in the top admin bar near the “Asset CleanUp” menu?

    The plugin has been tested extensively before the latest release and everything was well. However, it looks like there are issues for some websites. I want to offer you a Pro license as an apology for this inconvenience you had once everything is debugged, if you will still be interested of course.

    Thread Starter not1_name

    (@not1_name)

    Thank you. As our campaign has just started I won’t be able to test anything for a while. I’ll need to wait for the usage numbers to go down.

    Thread Starter not1_name

    (@not1_name)

    BTW, when I reverted back to to 1.3.6.0, all the extra unloads were still there. That is why I had to uninstall quickly. 20 errors on the home page alone. Now I know there is a reset button, I will wait until early in the morning and then then install and reset. Thanks.

    Plugin Author Gabe Livan

    (@gabelivan)

    @not1_name What kind of extra unloads were there? Per page, site-wide? Do you have a staging website or you only work on one (live) website? The best would be to check the “Overview” page. It has details about the rules you set, so you can clearly view the extra ones. Can you send me your “System Info” from “Tools” (plugin’s menu)?

    Thread Starter not1_name

    (@not1_name)

    > What kind of extra unloads were there? Per page, site-wide?
    Both

    > Do you have a staging website or you only work on one (live) website?
    Yes, We have a staging version. The update was only done to the live site. Wasn’t expecting what happened. Lesson learnt!

    > The best would be to check the “Overview” page. It has details about the rules you set, so you can clearly view the extra ones. Can you send me your “System Info” from “Tools” (plugin’s menu)?
    It’s Sunday evening where I am, and it has been a bit of a stressful evening with the site effectively going down a few minutes before a big campaign.
    I’ll contact you tomorrow when the dust settles.

    Plugin Author Gabe Livan

    (@gabelivan)

    @not1_name that’s quite surprising to be honest and you made me very curious about the reason behind this behaviour. Another user reported a similar thing, but it turned out it was something on his end. Perhaps it’s a similar matter in your case? You can check it out here: https://wordpress.org/support/topic/it-is-breaking-my-website/

    PS: I went through all the changes between 1.1.6.0 and 1.1.6.1 and I couldn’t find anything that would break the website the way you said. Something is very funny there, especially going from 17 rules to 117. I haven’t heard anything like that before. I still hope it’s an isolated case. My offer for the Pro license will always be valid once we sort out these issues.

    Thread Starter not1_name

    (@not1_name)

    OK, I think I have found the problem. And you’ll be happy yo hear that it isn’t your plugin! The site broke after the update. But we had earlier installed and set up “Autoptimize”. It must be related to how the 2 plugins interact. I deactivated Autoptimize, then activated your plugin first, then Autoptimize, and resaved the Autoptimize settings. The site is now working. I feel really bad about causing you to pull the latest version. It will probably be fine, but anyone with Autoptimize should probably deactivate first.
    BTW, the huge growth in rules was due to another developer working on our site update at the same time. As we are now working remotely (for obvious reasons), I didn’t know he had increased the rules, and only saw that when the site broke. Very sorry. Can I remove this thread?

    • This reply was modified 11 months ago by not1_name.
    Plugin Author Gabe Livan

    (@gabelivan)

    @not1_name Indeed, there are sometimes issues with Autoptimize and Asset CleanUp and in the latest release, 1.3.6.1, which was eventually pushed, the moment the caching is cleared in Asset CleanUp, it will trigger the cache clearing in Autoptimize. I’ve sometimes noticed that one has to lear both in some situations and some people might be confused to see a broken layout and they might not think of clearing both, so it’s automated now.

    Another known issue is with the minify HTML feature when it’s turned ON like explained here https://wordpress.org/support/topic/blank-homepage-when-minifying-html/ and here https://wordpress.org/support/topic/v1-3-6-1-breaks-site/ by @artio01 (in one of the latest comments from that topic).

    So, in case it happens the same for you, perhaps you can turn ON and OFF Minify HTML in Autoptimise and see if you will still have issues. From my experience and further testing, things like that are happening when there’s a large HTML output generated (e.g. lots of DOM elements) and due to low resources (e.g. memory), the minified HTML fails to generate. This happens whether Asset CleanUp is enabled or not. I’ve tested it in both situations.

    It’s strongly recommended to use such a function (minify HTML) together with a caching engine (e.g. Varnish) so that each page’s HTML is altered every couple of hours, thus saving you resources and not putting lots of pressure on the CPU/memory, especially if your website has lots of traffic.

    BTW, the huge growth in rules was due to another developer working on our site update at the same time. As we are now working remotely (for obvious reasons), I didn’t know he had increased the rules, and only saw that when the site broke.

    I have to admit that this was the most surprising thing of all and I felt it was an isolated case. I’m glad you figured it out eventually.

    I’ll mark this topic as “resolved”. I’m not sure if this topic can just be removed, most likely (if possible), it could be archived by one of the moderators.

    Thread Starter not1_name

    (@not1_name)

    Thank you for your detailed response. I appreciate it. As we knew what to look out for we have successfully updated to 1.3.6.1.We will be more careful with these 2 plugins in the future.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘DO NOT UPDATE TO 1.3.6.1’ is closed to new replies.