• Resolved o815

    (@o815)


    Hi,

    we noticed that when a page changes it state from published to draft, it still was visible in the menu
    a click on the menu item leads to 404 because it is in draft status

    how do we say max mega menu to show only published items and ignore the rest?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi o815,

    There’s nothing built in to WordPress or the plugin that does this automatically, so you’d need to use some custom code. Try searching for “wordpress menu ignore draft items”. This is the first result:

    https://deeperlook.com.au/blog/exclude-draft-pages-from-wordpress-menu/

    You would need to look through the results and find one that works for you.

    Regards,
    Tom

    Thread Starter o815

    (@o815)

    Hi,

    thank you for help, that did work indeed.

    yet this leaves a mega menu arrow > on the parent that indicates a child item. do you have a tip for this too?

    Plugin Author megamenu

    (@megamenu)

    Hi o815,

    I do not sorry, that is shown the menu thinks there are child menu items. You would need to use CSS to hide it, but then it might be less complex to remove the draft items from the menu instead.

    Regards,
    Tom

    Thread Starter o815

    (@o815)

    thank you very much, i now have all the information i need to decide which option to choose.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘do not show pages that is not in published state’ is closed to new replies.