Support » Plugin: Slider, Gallery, and Carousel by MetaSlider - Responsive WordPress Plugin » Do not show first image from slideshow as Feaured Image

  • Resolved Stuckindmud

    (@stuckindmud)


    We start the post with the Metaslider shortcode which displays the slideshow properly.

    Where we have a problem is although we have no Featured Image set, WP is showing the first image from the slideshow as the first image, followed by the slideshow repeating that image.

    We’ve read all the posts and references we can find but see no mention of how to solve this one. We are using WP 5.6 with the Version 3.19.1 version of Metaslider free version.

    The desired outcome is to show the slideshow only and the post content.

    thanks for any help.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor kbatdorf

    (@kbat82)

    Hi,

    That’s interesting because MetaSlider slideshows are created outside of the context of a page, so there shouldn’t be a way for WP to identify that unless your theme is filtering the loop looking for the image. I’m not sure I’ve seen that. Doe it happen on every page you place the slideshow on?

    Are you using the Divi theme? I believe they have an option to not include the featured image on the page.

    Thread Starter Stuckindmud

    (@stuckindmud)

    You were correct, Divi themes which we have on this site will use the first image as a first image unless you modify it’s behavior.

    We found the solution in Google and made the change and it fixed the problem.

    The post with the full info on it is at: go to Divi (or Extra) > Theme Options > Layout and disable Place Thumbs on Post in the Single Post Layout tab. … The post itself only shows the cover image.
    Thanks for your help, your clue got us thinking about the theme and all the settings in it, add some Google and the solution appears! Magic.
    Seriously, thanks for your help.
    best regards,
    James

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Do not show first image from slideshow as Feaured Image’ is closed to new replies.