Support » Plugin: Log Deprecated Notices » Do not allow what?

  • Could we please avoid naming capabilities like ‘do_not_allow”?

    $args = array(
    			'labels' => $labels,
    			'show_in_menu' => 'tools.php',
    			'show_ui' => true,
    			'public' => false,
    			'capabilities' => array(
    				'edit_post'          => 'activate_plugins',
    				'edit_posts'         => 'activate_plugins',
    				'edit_others_posts'  => 'activate_plugins',
    				'publish_posts'      => 'do_not_allow',      <=WTH?
    				'read_post'          => 'activate_plugins',
    				'read_private_posts' => 'do_not_allow',       <=WTH?
    				'delete_post'        => 'activate_plugins',
    			),

    it maps to nothing, has no meaning and causes lots of confusion when it shows up on the capabilities list. This is a very poor judgment IMHO.

Viewing 1 replies (of 1 total)
  • Plugin Author Aaron Jorbin

    (@jorbin)

    do_not_allow is a capability that is given to no user role and is even specifically denied to super admins.

    • This reply was modified 8 months, 3 weeks ago by  Aaron Jorbin.
Viewing 1 replies (of 1 total)
  • The topic ‘Do not allow what?’ is closed to new replies.