Support » Plugin: Regenerate Thumbnails » Do I have to manually change image source URLs?

  • Hi, I’m encountering the same problem as Faith (whose post was marked as resolved without further comment).

    I have run the plugin multiple times, and confirmed that the new full image size has been created in my FTP. But the images in all of my posts are still the wrong size. (You can see here how my images are extending past the width set by the theme).

    Is a feature of the plugin that the source links of the images will automatically update to the new size, or is this something I must update manually?

    Basically, am I encountering a problem with updating links, or was this not a feature of the plugin to begin with?

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same question als nnparisi. I was testing with a few images of recent posts, but they stay the same size inside the posts. I also tried the ‘Force generate thumbs’ plugin, but that one makes the thumbs disappear alltogether and I have to add them to the posts manually. Very glad I did not regenerated all the thumbs in my 2600+ posts 🙂

    Jack, I’ve ended up doing a manual fix for this in my child stylesheet. I added the following code to style.css:

    #main #content img {
    max-width: 620px;

    And that seems to have fixed it!

    Thanks for the suggestion 🙂

    I still hope there is a better solution for this, because ‘upscaling’ in this manner doesn’t make the thumbs look sharper :(.

    It regenerates the thumbnails but doesn’t reassign them. So then, what is the point?

    The only solution I’ve found is to rename the image, upload it again, delete the featured image and then choose the new one – the new dimensions for which are set in Admin > Settings > Media (doesn’t even involve the plugin).

    Am I missing something? 🙂

    Hi, I’ve been having the same problem with mine. I’ve been doing some trawling through trying to figure out where the issue is occuring, and I ended up at the function
    When I run a vardump on that function, I end up with this array:

    array(5) {
      string(51) "2013/11/Natural-undulating-surface-oak-flooring.jpg"
      array(0) {
      array(10) {
        string(0) ""
        string(20) "Canon EOS 5D Mark II"
        string(0) ""
        string(9) "Joe Clark"
        string(2) "45"
        string(3) "200"
        string(0) ""

    Which shows the image sizes metadata array is empty. So apparently the plugin has broken as of late, and is now clearing the sizes metadata from the database, meaning that the image_downsize() is failing.

    Any ideas?

    Same problem here with indeed all the metadata attributes empty. I’m now using “AJAX Thumbnail Rebuild” which works fine for me.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Do I have to manually change image source URLs?’ is closed to new replies.