Support » Plugin: PHP Compatibility Checker » Do about all plugins work on PHP 5.5?

  • Before I think about running this, I just wanted to ask a general question. I’m on 5.3.29, and for now, I’d just like to go to 5.5. My sites are too high-traffic to risk having a plugin issue that might arise at any higher release.

    My question is, does you all think that pretty much all reasonably popular plugins in use do work on 5.5? I would think so, but wanted to get opinions.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Contributor Taylor McCaslin

    (@taylor4484)

    Howdy Slobizman,

    It’s hard to say 100% certain, but in general most popular plugins are PHP 5.5 compatible. Certainly more are 5.5 compatible than PHP 7. However I have also personally encountered some less popular plugins that are not PHP 7 compatible.

    We certainly do however have customers at WP Engine who choose to remain on PHP 5.3 because they are not yet compatible with PHP 5.5, though that is usually because of legacy code they have written in their theme or custom plugin.

    Please do note that PHP 5.3 has been end of lifed since August 2014. 5.5 has been end of lifed since June 2016. Many host do maintain security releases for PHP 5.5

    Ultimately at WP Engine we recommend you test your site’s functionality on a new environment with the version of PHP you wish to use in production. If you are a WP Engine customer, you can contact support and ask them to do that. Other hosts may also be able to help you here.

    Hope that helps.

    I’m not on Wp-Engine, on LiquidWeb. Anyway, I installed your WP Control plugin in case I needed it, and that ran PHP Compatibility Checker on one of my 3 sites. It worked with no issues. I ran it to check PHP 5.5 and the only odd thing is that it says the Cloudflare plugin is not compatible with 5.5. I have a feeling that can’t be right since Cloudflare is such an important and updated plugin. Do you think this is accurate? Here’s the details:

    FILE: /home/********/public_html/wp-content/plugins/cloudflare/vendor/cloudflare/cloudflare-plugin-backend/src/SecurityUtil.php
    —————————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    —————————————————————————————————————————–
    13 | ERROR | The function random_bytes is not present in PHP version 5.6 or earlier
    —————————————————————————————————————————–

    FILE: /home/*****/public_html/wp-content/plugins/cloudflare/vendor/sebastian/global-state/src/Snapshot.php
    ————————————————————————————————————-
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————-
    383 | WARNING | INI directive ‘register_long_arrays’ is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    ————————————————————————————————————-

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Do about all plugins work on PHP 5.5?’ is closed to new replies.