• Resolved mniggemann

    (@mniggemann)


    Hi there,

    Maybe somebody here has an idea: when I insert a Vimeo video into a page with WordPress’ Vimeo oEmbed block, it automatically adds dnt=1 to the URL so Do Not Track is active.

    However, when I use this Lazy Load Videos plugin, the dnt appears to be stripped off. Any idea as to how I can keep it, is there a function?

    Cheers, -martin

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author kevinweber

    (@kevinweber)

    Hi @mniggemann, thanks for bringing this up. I hadn’t been aware of the dnt param but it definitely makes sense to support it, just like I’m supporting the equivalent privacy-friendly Youtube URLs. I’m hoping to get to it on the weekend.

    Thread Starter mniggemann

    (@mniggemann)

    Hi Kevin, oh that’s super nice, looking forward to it!

    Have a good weekend,
    -martin

    Plugin Author kevinweber

    (@kevinweber)

    @mniggemann Hi, I just looked at my test site and it should already be the case that the dnt query param doesn’t get stripped from the embed URL. Can you provide me the exact embed URL that you’re using so that I can try and reproduce the issue myself?

    Thread Starter mniggemann

    (@mniggemann)

    Hi Kevin,

    Here’s a demo page https://filmwerkstatt-muenster.de/test-vimeo/

    Thanx for having a look!
    -martin

    Plugin Author kevinweber

    (@kevinweber)

    Thanks for the details! I just published a new version of the plugin, v2.17.0, where I add “dnt=1” to all Vimeo videos to minimize tracking by default. Make sure to do a “hard refresh” of your browser window (clear cache) to load the latest JavaScript code after updating the plugin. This should resolve your dnt issue. Please let me know if your issue is resolved.

    There’s a new option in the admin panel to opt out of this feature and enable tracking, in case that’s desired.

    Note that I’m aware of a different issue affecting videos that are unlisted/private (as indicated by the “h” query param: “h=aeae30e4fb“). My plugin doesn’t seem to handle those and I’ll need to look into this separately.

    Plugin Author kevinweber

    (@kevinweber)

    Hi @mniggemann, I just published v2.18.0 with support for the h query param. I hope that helps. Cheers!

    Thread Starter mniggemann

    (@mniggemann)

    Hi @kevinweber, that’s great, thanx a lot!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘DNT parameter is lost’ is closed to new replies.