Support » Installing WordPress » “DNS error or cannot find server” message on wp-

  • I decided to move this one into its own thread because it’s a different problem than the one that I reported (and fixed) yesterday. After installing 1.0.2 on Tru64 Unix running Netscape webserver, I can get to the first page of the weblog. It appears to be set up correctly.
    The problem is that any link I try to follow off of that page that references a file in wp-admin (such as login, edit this post, etc.) results in a “Cannot find server or DNS error” message. I can’t access any of those files by directly typing the URL into the browser, either — same error message.
    I can place a .html or .php file inside the wp-admin directory and see it just fine in the browser, but the files supplied by WP just generate this error message.
    Permissions on the directory and its file have been opened to 755 to see if that was the problem (no effect).
    My sys admin and I are both stumped — I’ve looked at the code and don’t see anything that should be triggering this type of problem, and can’t think of what else to try. Any suggestions?
    Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Matt Mullenweg

    (@matt)

    Troublemaker

    If you’re in IE try turning off “friendly error messages” in your options and I’d also try a different browser like Firefox. See if that shows you a more helpful error message.

    Allusion,
    Tried ALL of your advice. Now I’m getting some even odder results.
    Turning off “friendly” error messages didn’t really help in IE, or tell me anything more/different than previously.
    Doing the same in Netscape, however, now generated a “document has no data” error message.
    Firefox loads a blank page or just reloads whatever page I was previously on, but doesn’t generate any error message.
    I’ve tried directly accessing wp-admin/index.php, post.php, profile.php and edit-comments.php.
    Profile.php generates a form that looks right and “seems” to act correctly, although it returns me to the wp-admin index page that won’t display. Same thing with edit-comments.
    So it seems that there is a terminal error of some type with post.php, but I can’t see anything in the code that might be triggering it.
    K.

    More info on this problem to help with diagnostics….
    I’ve definitely isolated the problem to wp-admin/post.php. I’ve also upgraded to last night’s nightly, with no progress on the issue.
    Within post.php, I added a print statement at the beginning of the file, and that print statement echoes out to the browser correctly when I access the file. The rest of the output is then blank. Without the print statement, or with it commented out, the blank “document contains no data” condition continues to be returned in all browsers.
    So it seems pretty clear that post.php is encountering some issue that is causing it to return no data from its processing (including no header). I find it difficult to believe that I’m the only one seeing this issue!
    As of now, I’m dead in the water with this implementation, so would love to hear any thoughts on how to proceed further.
    Thanks!

    I don’t know about in the more recent verisons of WP, but at least in mine, post.php does includes based on the action being performed (basic post screen or advance posting scrteen). I’m wondering if there’s a problem with that. Like it isn’t including the proper file, or if there’s a file missing.
    TG

    TG, Great idea, but I’ve checked the code for includes and found that all of the referenced files exist. I haven’t traced THROUGH all of those files to see if any buried requires might be missing, though. I’ll take a look tonite.
    However, I’d expect to at least see an error message generated if that was the issue (like the ubiquitous “Cannot open required file” message PHP throws).

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘“DNS error or cannot find server” message on wp-’ is closed to new replies.