Support » Installing WordPress » DIYer 3.3 install = "Uncle!"

  • Disclaimer: I’m right-brained, and most definitely not at home with coding.

    I have been slogging through upgrading to 3.3 for days. I got some help with the final step of the install from my hosting provider, but I have hit a wall. I’m past the tears point and now it’s me vs this software, but I need some help.

    My cPanel shows that I have all the files and folders, however my admin and my cP aren’t speaking. Everything is there, but my admin panel says I don’t themes, I don’t have permission for anything, just nothing. I’m also running Firefox on Vista (don’t get me started).


    To further complicate things… : ) …my site might be getting media attention next week, and I’m hoping that 404 won’t be my business message. <wince>

    Thanks for any ideas. And just to remind, right-brained creative type here, so yall coding smarties may have to dial it down a few notches. ; ) But seriously – THANK YOU for any help. I appreciate it a ton!

Viewing 10 replies - 1 through 10 (of 10 total)
  • ps…I used FileZilla to do my installations (don’t know if that makes a difference in trouble-shooting), and my website is

    Thanks again, poets. : )

    Trying to figure this out…

    Trying to see if there is something wrong with wp-config file. WP installation said I didn’t have the config-sample.php file, so reupped it, and went to wp-admin/setup-config.php again. This time, I got this error message:

    Fatal error: Call to undefined function __() in /home/mydomain/public_html/wp-admin/includes/file.php on line 11

    This is what that file reads on lines 9-13:
    9 /** The descriptions for theme files. */
    10 $wp_file_descriptions = array(
    11 ‘index.php’ => __( ‘Main Index Template’ ),
    12 ‘style.css’ => __( ‘Stylesheet’ ),
    13 ‘editor-style.css’ => __( ‘Visual Editor Stylesheet’ ),

    Am I headed in the right direction to look at this? If so, is this what this file is supposed to look like?

    Just deleted my wp-config to make it from scratch in the setup from the wp-admin/setup-config.php URL. I plugged in my database info, clicked submit, and this is the next (and very familiar) error message:
    Sorry, but I can’t write the wp-config.php file.

    You can create the wp-config.php manually and paste the following text into it.

    I noticed that the text of the config.php example doesn’t end in ?> …are php files supposed to end with nothing, like in my c/p example from the WP setup screen?

    Current step:

    Made the new wp-config.php; now have that and wp-config-sample.php in my root directory.

    This is the error message that I see in my WP admin:

    Warning: uksort() [function.uksort]: The argument should be an array in /home/mydomain/public_html/wp-admin/includes/class-wp-themes-list-table.php on line 48

    Warning: array_slice() expects parameter 1 to be array, boolean given in /home/mydomain/public_html/wp-admin/includes/class-wp-themes-list-table.php on line 55


    Boolean sounds suspiciously like moonshine…

    Just deleted wp-config-sample.php via FileZilla. No change in the error message.

    Has anyone successfully figured this out? I’ve worked with WordPress for a few years, albeit not consistently, but this makes me wonder if I need to ditch it in favor of something that can get my business online. Time is precious. :-/

    I asked my host to check the error logs; no improvement.

    I deleted all themes (via FZ) except for TwentyTen. Then went to install Twenty Eleven, and here is the new round of error messages:

    Warning: fopen(/home/mydomain/public_html/wp-content/themes/twentyeleven/style.css) [function.fopen]: failed to open stream: Permission denied in /home/miracoli/public_html/wp-includes/functions.php on line 4443

    Warning: fread(): supplied argument is not a valid stream resource in /home/mydomain/public_html/wp-includes/functions.php on line 4446

    Warning: fclose(): supplied argument is not a valid stream resource in /home/mydomain/public_html/wp-includes/functions.php on line 4449

    Becoming ever more cluelesser by the click.

    Have a help ticket with my host.

    Apparently, I had the wrong host name in there, so we got that fixed, and… <drumroll, please> …still nothing.

    This is the latest message from trying to install the ColorWay 1.7 theme:

    Downloading install package from…

    Unpacking the package…

    Installing the theme…

    Successfully installed the theme ColorWay 1.7.

    Warning: fopen(/home/mydomain/public_html/wp-content/themes/colorway/style.css) [function.fopen]: failed to open stream: Permission denied in /home/mydomain/public_html/wp-includes/functions.php on line 4443

    Warning: fread(): supplied argument is not a valid stream resource in /home/mydomain/public_html/wp-includes/functions.php on line 4446

    Warning: fclose(): supplied argument is not a valid stream resource in /home/mydomain/public_html/wp-includes/functions.php on line 4449

    My main issue seems to be that WP can’t write to my server. What’s the right approach to fix that?

    It sounds like you’re having a permissions issue. It’s not specifically WordPress, but rather PHP itself. PHP and your server software (most likely Apache) aren’t playing nice. PHP can’t write files to the directories on your server, so its puking up errors.

    I usually solve this with a simple chown -R www-data:www-data public_html command so that the Apache user owns all of the directories PHP is attempting to manipulate and can let it access them… but if you’re not managing your own server or don’t have command line access to your server, it’s something your host is going to have to fix for you.

    I got it all worked out. Or rather, my host did [she’s awesome].

    The problem for me, which many newbie/rookie/everyday joe’s like me might want to double-check is the name of the host that’s put into the FTP upload space. I had the wrong hostname in my database info in my wp-config file, and had put it in there based upon a wrong assumption.

    Getting the hostname correct fixed the entire problem for me. Go figure. O; )



    Guys…..i have changed the folder public_html permission in files-manager to 755…and creating the file is fine!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘DIYer 3.3 install = "Uncle!"’ is closed to new replies.