Support » Plugin: Content Visibility for Divi Builder » Divi Page Settings – missing options

  • Resolved Bernard Lemieux

    (@blecreateur)


    Hi,
    When the plugin is activated on my site, I lose two options from the Divi Page Settings window. Hide Nav Before Scroll and Post Title display options disappear. These options come back when I disable the plugin.
    Thanks,
    Bernard

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter Bernard Lemieux

    (@blecreateur)

    Hi,
    Just realized that this issue was raised by stevegayler 6 months ago.
    I can provide login to my site if required.
    Thanks,
    Bernard

    Hi, I don’t know where else the problem might be, but it works for me on the test site even though I have the plugin turned on.

    Thread Starter Bernard Lemieux

    (@blecreateur)

    Hi,
    Thanks for your reply.
    One thing I forgot to mention is that I have the Classic Editor enabled. My hosting configuration is compatible with Divi. I use PHP version 7.4.

    I just tried again on a clean local site, installed latest release of Divi and Content Visibility plugin is the only plugin installed. No Child theme, no custom php, css, js. The problem occurs (with the Hello World! default post) when the plugin is active only.

    The web inspector shows that there is a “display: none;” style for the following p classes:
    et_pb_page_settings et_pb_single_title
    et_pb_page_settings et_pb_side_nav_settings

    Not sure what else I can say.

    Plugin Author Jonathan Horowitz

    (@jhorowitz)

    @blecreateur, thank you for the additional information! Could you also check if there are any errors in the console? We do not add display none anywhere directly, perhaps a js error is stopping the Divi code from unhiding those at some point?

    Thread Starter Bernard Lemieux

    (@blecreateur)

    There are no errors. Just a few warnings that are also present when the plugin is deactivated.

    I am using Chrome. I will try with a few other browsers.

    Anything else I can try?
    Thanks,
    Bernard

    Thread Starter Bernard Lemieux

    (@blecreateur)

    Same behaviour on Safari and Firefox.
    Thanks,
    Bernard

    Thread Starter Bernard Lemieux

    (@blecreateur)

    Hi,
    There is no problems with Divi Page Settings when using the “Gutenberg” block editor.
    If this can help.
    Thanks,
    Bernard

    Plugin Author Jonathan Horowitz

    (@jhorowitz)

    In the Classic backend editor, I still see the Hide Nav Before Scroll setting (within a p tag with class=”et_pb_page_settings et_pb_nav_settings”. This is directly below the display: none’d et_pb_page_settings et_pb_side_nav_settings, which is for Dot Navigation (according to its label).

    When I click the cog at the top right of the backend builder, I see Post -> Title field…

    Since this is still not reproducible on our end, there isn’t much we can do here…

    Plugin Author Jonathan Horowitz

    (@jhorowitz)

    @blecreateur I just realized you offered to give us a login to diagnose on your site; could you please send the credentials for the test site you have setup with just our plugin and divi that displays the issue here: https://aod-tech.com/contact/

    Thank you!

    Thread Starter Bernard Lemieux

    (@blecreateur)

    Done. Let me know how it goes.
    Thanks

    Plugin Author Jonathan Horowitz

    (@jhorowitz)

    Hi @blecreateur,

    Running into a lot of rate limiting issues with ngrok; that said, I did see the Hide Nav Before Scroll option on the page (might not be the best test with some network requests failing, however…)

    I have emailed over a screenshot of what I am seeing when I go to edit the Hello World! post with Divi Builder enabled.

    Plugin Author Jonathan Horowitz

    (@jhorowitz)

    Version 3.16 has been released which should fix this issue; please let me know if you have any additional feedback after updating and thanks again for using the plugin (and helping me troubleshoot this issue!)

    Thread Starter Bernard Lemieux

    (@blecreateur)

    Awesome!
    It works now,
    Glad I was able to help.
    Thank you very much.
    This plugin is very helpful to me.
    Cheers,
    Bernard

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.