• We have a number of websites for our clients using the Divi contact form.

    After some an intermittent number of days the contact form shows error on submitting “Please refresh the page and try again”

    If I purge all in Lite Speed Cache the issue is resolved for a few days.

    I have raised a support chat with Divi and they have confirmed

    Thank you for contacting ET Support. If the issue is solved after the LiteSpeed cache clearing, then it comes from that plugin. It usually happens when the nonce is cached and if this nonce is expired it will fail. 

    I checked Lite Speed documentation on ESI Nonce and see a predefined list which included the Divi contact form see https://github.com/litespeedtech/lscache_wp/blob/master/data/esi.nonces.txt

    However we still getting the error.

    I have applied *et* to the ESI nonce list in Lite Speed plugin settings and purged all site cache. solution found in older thread here.

    I have approximately 50 websites that I need to identify the problem with and apply a working solution for all of them.

    Will the *et* fix the problem or should the predefined list be doing all the necessary exclusions?

    Report number: DXWNEWZQ

    Report date: 09/10/2023 22:17:19

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support qtwrk

    (@qtwrk)

    from report , you did not enable ESI, ESI nonce needs ESI option to be enabled.

    Thread Starter thyran

    (@thyran)

    Hi There

    Thank you for the quick reply.

    I have re-enabled ESI and removed the *et* from the list and Purged All cache.

    Was this all that I was missing to enable ESI option.

    I will test over the next few days to ensure everything is working as intended.

    Plugin Support qtwrk

    (@qtwrk)

    sure, please keep me posted.

    Thread Starter thyran

    (@thyran)

    Can you let me know more about the ESI noonce and predefined list which includes elements from the Divi theme builder

    et-pb-contact-form-submit

    et_frontend_nonce

    et_ab_log_nonce

    Was ESI not being enabled the cause of the submission error “Please refresh the page and try again”

    If so I will go and enable ESI on our other sites

    It may take up to a week for me to verify this issue is resolved as the issue presented itself at irregular intervals only after a few days.

    Thank you

    Plugin Support qtwrk

    (@qtwrk)

    Thread Starter thyran

    (@thyran)

    Hi There

    Thank you I have reviewed that link as per my original post

    “I checked Lite Speed documentation on ESI Nonce and see a predefined list which included the Divi contact form”

    It only states it has the blocks for the Divi visual builder and lists them but does not explain why and what is the cause. The documentation is also outdated in the sense that it says we must fetch the predefined list from a button which no longer exists on the plugins ESI page.

    I assume this list is being merged with git as this is what the plugin is stating.

    When I enable ESI on glidingtauranga.co.nz I loose the Divi slider image and google map on the home page? They re-appear as soon as I disable ESI .

    See https://snipboard.io/0jpsUq.jpg

    Developer console shows following errors

    https://snipboard.io/EZMWOY.jpg

    https://snipboard.io/eonTut.jpg

    • This reply was modified 10 months, 1 week ago by thyran.
    Plugin Support qtwrk

    (@qtwrk)

    the error you posted is more about JS error it seems

    if you reset to default and only enable ESI, what happens by then ?

    you should use et* though

    but does not explain why and what is the cause

    please forgive my bluntness , could you please explain a bit why what and cause of what ?

    the nonce issue ?

    Thread Starter thyran

    (@thyran)

    Hi

    why and what the cause I am referring to is what is causing the issue with Divi contact form submission issues that it needs to be added in the predefined list.

    I added *et to glidingtauranga.co.nz and enabled ESI but the issue persists with the divi image missing from the slider and google map not displaying see

    https://snipboard.io/0jpsUq.jpg

    https://snipboard.io/EZMWOY.jpg

    https://snipboard.io/eonTut.jpg

    Plugin Support qtwrk

    (@qtwrk)

    the wildcard symbol should be placed after , not before

    have you tried all default + ESI enabled only setting ?

    Divi team explained it already I think , the nonce token has a life time , and once it is cached on page , it may expire , so you are sending an expired token to system , then system will reject as invalid , if this was your question…

    Thread Starter thyran

    (@thyran)

    Hi Thank you for the feedback.

    That was a typo I did try the star after et* but this still didn’t have any effect.

    I backed up the LS settings reset to default and enabled ESI with and without et* clearing cache between adding it but unfortunately I am still getting the same display issue.

    Thanks for clarifying the issue is as Divi support team advised.

    Plugin Support qtwrk

    (@qtwrk)

    okay , please create a ticket by mail to support at litespeedtech.com with reference link to this topic , we will investigate further.

    Thread Starter thyran

    (@thyran)

    Hi Thank you

    I emailed support yesterday before lunch I will wait to see if I hear back from them.

    Thread Starter thyran

    (@thyran)

    Hi There

    I have this issue returning on a different website where ESI is enabled?

    Had to clear the cache to get it working again.

    Why would I be getting the issue now with ESI enabled in LS Cache?

    Thread Starter thyran

    (@thyran)

    Not sure how to mark this support topic as unresolved after it has been resolved…

    Maybe Admins can do that for me 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Divi contact form issue with LiteSpeed plugin’ is closed to new replies.