Support » Plugin: Autoptimize » Divi & Autoptimize errors

  • Resolved MagineM

    (@maginem)


    Hi,

    When I activate Autoptimize on my site running Divi, the mobile menu as well as scroll down script on the home page don’t work. It sometimes works when testing through dev tools on my desktop, but when using an actual mobile device, it doesn’t work.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • No worries. Think I solved the problem by changing a mobile setting in WP Super Cache.

    • This reply was modified 5 months, 1 week ago by MagineM.
    • This reply was modified 5 months, 1 week ago by MagineM.

    UPDATE: I thought it had fixed it, but unfortunately not. So still sitting with the same problem 🙁

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Could be due to CSS or JS optimization, try to identify which one by disabling (and re-enabling) CSS optimization and then JS optimization. once you know that you’ll have to look into which CSS- or JS-file to exclude from optimization to fix. If JS then the browser console might have JS errors that can help identify the root cause (my money is on themes/Divi/js/custom.js but maybe you’ll need to use themes/Divi/js/ or even themes/Divi instead)

    AO’s FAQ has more info on troubleshooting and how to exclude.

    hope this helps,
    frank (ao dev)

    Hi,

    Thanks for the feedback. Oddly enough, the only error I get is that the
    /wp-content/cache/autoptimize/js/autoptimize_b428ba7f8d4636e2ab040ce82ca510e8.js fails to load.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    That’s weird. I tested and indeed see that as well. AO’ed files are written to cache and are entirely static, once saved AO does not have to intervene any more. is this a loadbalanced site maybe, where one server might have autoptimize_b428ba7f8d4636e2ab040ce82ca510e8.js and the other one not?

    Hi, I’m actually not sure about it being load balanced. I’m also running WP Super Cache… could that possibly be causing some issues?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    no WP Super Cache cannot cause that (I use it too). can you check with your developers/ hoster about loadbalancing?

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    any news on this @maginem ?

    MagineM

    (@maginem)

    Hi,
    My server is not load balanced. Have not spent much more time on this, but the site does still tend to run slow in the backend. I have excluded the custom.js which seems to have sorted out the mobile issues.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Afraid AO can’t help with backend speed, but happy the mobile issues was sorted out 🙂

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.