Support » Plugin: Duplicator - WordPress Migration Plugin » DIVI and Duplicator Issue – Investigations

  • Resolved Sofian777

    (@sofian777)


    Hello, I am one of many users of the fabulous DIVI theme, but unfortunately there are issues when using Duplicator for moving the site.

    There are two problems that show up after moving a DIVI site with Duplicator:
    1. all special characters are replaced by a ? in a rhombus, a typical sign of collation problems
    2. editing a page that was build with the DIVI builder shows the DIVI builder activated but completely empty, yet I guess the problem is based on the same issue and once it is solved the builder will work fine again as well.

    It seems that the UTF8mb4 that was integrated few month ago into WP, together with the DIVI theme, and the way Duplicator works, is causing these failures. Since it will not help anyone if every party says “it is not our fault, the other guys have to fix it”, I kindly asked the DIVI team to give it a try, recreating the issue by using Duplicator and trying to figure out all they can and let us know, hoping that we will be able to fix it together.

    When you read about the ? in a rhombus error, do you have a clue what we could try, e.g. another way of transfering the database?

    If you allow me to contact you by mail, I could give you access to a site with the issue or send you a duplicated database, so you can have a look into.

    Thank you very much for this nice plugin and your support.
    Sofian

    https://wordpress.org/plugins/duplicator/

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Sofian777,

    There are some workarounds for the UTF8mb4 issues that can be found here. The pro version has a feature that tries to fix this on the fly which has worked on some versions of Mysql for various users.

    Hope that helps!

    Thanks for fast reply and the link. So if the issue is not only in connection with the DIVI theme but also appears elsewhere and you found a solution for the PRO version, are you working also on fixing it generally throught your fabulous plugin, meaning can I hope to use Duplicator in the standard version one day again on all my sites without workarounds? That would be great. Thanks for the great work, have a nice weekend.

    Hey Sofian777

    I am facing the same problem…………….did you resolve it ??? or did you get reply from elegant themes ?

    As reading through the solutions Cory linked to, I see that the problem lies in Duplicator and the db multibyte collation, or not even in Duplicator, but also in MySQL version on the server. ET didn’t reply and I now don’t see any option which they should do on their side.

    As long as Duplicator is not integrating the workaround into the free Version, we have to workaround the issue ourselves, so I hope Cory is considering to offer it to everyone. For me the PRO version is honestly to expensive since I use Duplicator only for moving sites once, and it doesn’t come with an unlimited time and -domain offer. Paying $49 once for being allowed using it for moving all my domains would be considerable for me. Anyhow it is possible to make a donation to honor his work, because what he gives with the free version is enormously great, and I hope the solution for the bug that apparently limits its usage in various cases and environments will be included as well for the free users.

    From the Duplicator workarounds this one here seems the easiest:
    https://wordpress.org/support/topic/can-duplicator-handle-different-collation-methods-between-mysql-versions

    But I wonder if cutting off multibyte collation will not generate other issues later on.

    In the ET forums there was this plugin suggested, and if this one does the migration correct, then actually it can also be considered a workaround, I will try this week:
    https://wordpress.org/plugins/wp-migrate-db/

    If anyone else found another easy workaround, or if there are news regarding Duplicator updates that solve it, please let us know.

    Great days
    Sofian

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Sofian,

    Its currently in the backlog to migrate into free, the pro version has a full time developer so features and support is much faster, free is still volunteer work so it will take some time as there are a few other requested items ahead of this…

    Thanks

    Great, thanks for giving it to the free users as well. I mark this topic as resolved.

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks! It may be a while but it will eventually get into the Free version. Its officially on the todo list.

    Unfortunately the script didn’t work in my situation 🙁
    Also the plugin WP Migrate DB produces the same errors.

    So for the moment the only way is the manual phpMyAdmin export-import.

    Since posting here and in DIVI forum is double work I create a post on my website to keep everybody up-to-date and hopefully people to join the investigations:
    http://wptraining24.com/divi-duplicator-database-migration-problems/

    Another question, are you the owner of snapcreek who distributes Duplicator Pro, I mean does the sale of a Pro license support your personal life and not other guys? (I need to ask here because lifeinthegrid and snapcreek seem to have no connection and you are very sparse with contact informations and disclaimers 🙂

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Sofian,

    Yes I am a partial owner in snapcreek. LifeintheGrid is my personal site and where I started the free version from. Since then I have teamed up with another developer who works on the Pro version full time. I currently still need a full time job, so I don’t really get to help out much with Pro, but a few hours a week. The remaining time is spent helping out with the free version. Someday hope to work on Pro full time and dedicate more time to the free version as well.

    Hope that helps clear up the connection…

    Cheers~

    Hello all. I came across this thread researching a problem I was having. Sofian77 was having the EXACT same issue. I used Duplicator to move a Divi site to another host. I experienced the same problems in the backend and even had the question marks appear. I researched and tried several fixes but to no avail.

    The solution was to change the php version 5.2 to 5.4 and then everything started working.

    Cory, let me say that I am a huge fan of Duplicator. It is on my list of must have plugins. I hate using the free version but as Sofian mentioned, the pro version makes no sense. With that being said, perhaps you can add a php version test as a feature. It would be nice to see a warning when installer.php runs and the PHP versions don’t match. In this case, it would have saved me hours.

    Cheers!

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Gulfwebdev,

    Thanks for the suggestion, a version comparison warning would be a nice enhancement, will add to the todo list.

    Thanks~

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey Everyone on this thread,

    The developer version now has a new option similar to pro on the database tab called “compatibility mode” This can be used to generate an older mysqldump script for older databases. The very latest version (1.1.0) can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Click on “Development Version” link and download the zip plugin file
    -> Uninstall your current version and install this one

    Let me know if this solves your issue…

    Thanks

    Finally I have a alternative solution

    https://wordpress.org/plugins/all-in-one-wp-migration/

    really loving it

    still missing duplicator

    Finally I have found an alternative solution

    https://wordpress.org/plugins/all-in-one-wp-migration/

    really loving it

    still missing duplicator

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘DIVI and Duplicator Issue – Investigations’ is closed to new replies.