WordPress.org

Support

Support » How-To and Troubleshooting » DIV and Paragraph beheaver in 2.1

DIV and Paragraph beheaver in 2.1

  • I have just updated to 2.1 from 2.0.7

    I used to have my widescreen images in div’s and that worked great. But now WordPress changes my entries from <div>blabla</div> to <div>blabla</div>. So now the images appear with a small margin to the left.

    Is there a possible way to change this back?

    (see for yourself: http://www.nehold.com)

Viewing 15 replies - 1 through 15 (of 75 total)
  • Thought that I fixed it, but it keeps on creating a without any reason!

    Related: around my <!--more--> (on the site: “Lees meer”) it also creates <p>..</p> without reason.

    Samuel B
    Participant

    @samboll

    Do you have the wysiwyg editor turned off and it still has this behavior?

    Yes, and the source code of the posts doesn’t have the <p> after my <div>‘s, that’s what so weird. It must be something inside the WordPress source code?

    Samuel B
    Participant

    @samboll

    I haven’t seen this reported on the forum but I could have missed it. I’ll look into it.

    edit – btw, I don’t see this behavior in FF.
    Also, look at some of these:
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.nehold.com%2F

    Several of these errors haven’t been here before.. But I will see what to fix, and check back then. THNX!

    samboll: This problem has been reported before. WP 2.1 is inserting extraneous P tags in various places, and often it’s not closing them. Check this out:

    http://wordpress.org/support/topic/101822?replies=6

    I thought I saw it elsewhere but could be wrong.

    I specifically downgraded from 2.1 to 2.0.7 to fix the invalid XHTML issue this created (I post a lot of photos using DIVs). Despite the downgrade problems with links and pages, it was worth it to get the site working again. Once I switched back to 2.0.7, all the problems went away, the extra tags disappeared, and my site once again validates as XHTML.

    It seems 2.1 is inserting extra tags unnecessarily, and it’s doing so to the detriment of valid code and usability.

    Same problem here. P tag is inserted before Img tag and div tags. All my images gone from FF 🙁

    Whow, glad I’m not the only one who has this (but sorry that it even exists).

    There isn’t any way to bypass this whole problem temp, before another release comes out?

    “Whow, glad I’m not the only one who has this (but sorry that it even exists).”

    Me too, I uploaded and installed to 2.1 a couple of hours ago and have been fighting the dreaded <p tags ever since.

    All of my images are posted inside Divs and all are being pushed to one side … see here; http://www.barganews.com/

    I will wait another couple of hours to see if somebody comes up with a quick fix – if not then its back to 2.0.7 until this is sorted …. shame but we do at least live in interesting times don’t we ?

    ciao
    db

    If you edit or save post it will not insert P tag. But when browser request url it will automatically insert P tag. I was just wondering if anyone knows the name of PHP file /code which displays post to end user.

    I see it’s not just with DIV tags:

    http://wordpress.org/support/topic/101937?replies=1

    It’s really weird 🙂 I’m waiting a week for a fix to come along, and then I’m switching back to 2.0.7

    It is a shame, ’cause 2.1 is so much better for me in all the other areas! (I had a huge problem with post.php and that is all fixed now.)

    xenogere: so, it’s an all-round problem than.

    Maybe 2.1 should be placed on hold untill this is fixed?

    I saw it mainly with DIV tags used for images, bit it also inserts them around LABEL and TEXTAREA tags as well as the <!–more–> metacommand. It’s quite odd–like an overzealous content filter in the display code (it has to be in the display code only since the extra tags aren’t stored in the posts).

    fix22: I’d recommend holding off on the upgrade until this and a few other issues are resolved (like the non-standard XMLRPC interface).

Viewing 15 replies - 1 through 15 (of 75 total)
  • The topic ‘DIV and Paragraph beheaver in 2.1’ is closed to new replies.