WordPress.org

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] Distorting new thumbs but old ones remain perfect (9 posts)

  1. Sharon
    Member
    Posted 12 months ago #

    Hi there,

    Bit of a strange issue has popped up. I have the following in my child theme php and it was working well. Images were the correct size.

    add_image_size('yarpp-thumbnail', 105, 150, true);
    
    define('YARPP_GENERATE_THUMBNAILS', true);

    This is working perfectly for images that are "old" (ie. that were in my media folder when I asked YARPP to display thumbnails), but new images that I add for new posts are being distorted within the YARPP display. The pic of the Honeydew Apple Juice here, for example, is one that I've just added this morning.

    Is there a way around this?

    Regards,

    Sharon

    https://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 11 months ago #

    You shouldn't need the define('YARPP_GENERATE_THUMBNAILS', true); if you already have the add_image_size line. Please try removing define('YARPP_GENERATE_THUMBNAILS', true); and seeing if it fixes future image uploads. Thanks!

  3. Sharon
    Member
    Posted 11 months ago #

    Hey Jeff,

    thanks for getting back to me, and sorry for my delayed response. I've removed

    define('YARPP_GENERATE_THUMBNAILS', true);

    from my php but it doesn't seem to have changed things. New images are stretched, but the old ones are perfect....

  4. Sharon
    Member
    Posted 11 months ago #

    Hi,

    Sorry to be a pain. Since my last post where I mentioned that I'd removed the php as discussed, I've also attempted to regenernate the "offending" thumbnails using Regenerate Thumbnails.

    This doesn't seem to have worked either. Wondering if anyone might have suggestions as to anything else I could try.

    Regards,

    Sharon

  5. jeffparker
    Member
    Plugin Author

    Posted 11 months ago #

    Our latest release may be overriding your setting perhaps. The YARPP thumbnails on your site are actually 84 x 120, which is even smaller than the 105 x 150 you listed at the top of this thread.

    I'd recommend editing the add_image_size line and then running Regenerate Thumbnails for all posts at the 84 x 120 size. Please back up your site beforehand.

    Hope this helps.

  6. Sharon
    Member
    Posted 11 months ago #

    Hey Jeff,

    Sorry it took me so long to reply. I tried your suggestion and it seems to have worked. Thanks very much.

    Regards,

    Sharon

  7. jeffparker
    Member
    Plugin Author

    Posted 11 months ago #

    Glad to hear!

  8. Sharon
    Member
    Posted 10 months ago #

    Hey Jeff,

    Sorry to comment on a post I had previously closed but just wanted to add an update.

    Over the last week or so, I've noticed the "Regenerate Thumbnails" no longer worked (for reasons unknown....??). My images in Yarpp were continuing to be completely distorted. So I downloaded and ran Simple Image Sizes.

    This has worked perfectly where "Regenerate Thumbnails didin't. I just wanted to let you know in case you run across anyone else with the same issue.

    Cheers,

    Sharon

  9. jeffparker
    Member
    Plugin Author

    Posted 10 months ago #

    Thanks for letting me know, Sharon. I'll also recommend Simple Image Sizes in the future.

Reply

You must log in to post.

About this Plugin

  • Yet Another Related Posts Plugin (YARPP)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic