Support » Localhost Installs » Distorted information

  • Dear support i need assistance to setup wordpress on a localhost server. I have managed to setup without trouble and the hosting computer is showing nicely but i try access the site through LAN on another laptop i get distorted information including the logo is not showing. I have tried with setting up using Xamp, Mamp wamp and amp am still experiencing this problem. I have also attempted to change themes i still experience the same problem and also attempted to take out all plugins.

    Kindly assist.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    IF your site’s url is “localhost”, the site cannot be viewed on other computers. “localhost” is a very special address. Give your site a real URL (for example, mysite.local) and either add that to the DNS for your LAN or add an appropriate entry to the host files on both the website’s computer and the other computers on the LAN.

    Yes i perfectly understand. I have given the server an ip address and am accessing the website through the ip e.g http://192.168.1.200/wordpress. The website is opening but with distorted information probably something to do with format or cascading not very sure what is happening when i try to view the site using another machine is not hosting it.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    Use the browser’s error console to see what might be a problem. You may not be loading CSS files.

    Learn to use the Chrome Developer Tools or Firefox Developer Tools.

    Hi i have seen it using chrome developer tool I am getting errors. “Failed to load resource: net:: ERR_CONNECTION_REFUSED (localhost/eforms/wp-includes/css/dist/block-library/style.min.css?ver=5.2.1”)

    Would you know how to resolve this issue?

    Connection Refused i think is the main error.

    Moderator Steve Stern

    (@sterndata)

    Support Team Volunteer

    The URL includes “localhost”, which means the browser is looking for the CSS file on the local machine, not on the machine on which WP is living. You need to fix all localhost references. You can do this with a plugin like ‘better search replace’. Search for http://localhost and replace with http://192.168.1.200/wordpress.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.