Support » Plugin: Autoptimize » Disqus Comments

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Frank Goossens

    (@futtta)

    Afternoon Rui;
    On my test-instance I have Disqus working without any special configuration in Autoptimize (no need to have AO preserve HTML-comments), but there might be some other things going on. I would suggest to have a look at the FAQ for info on troubleshooting.

    My best guess; there are JS-errors due to optimization that impact Disqus. Look at your browsers error console to get an indication of what to exclude from optimization and adapt your AO config accordingly.

    Good luck!
    frank

    Plugin Author Frank Goossens

    (@futtta)

    Hi Rui,
    I saw on Twitter you’ve disabled Disqus as you couldn’t get it to work. If had a quick look at opcoesbinarias (which I guess is the site on which you have the Disqus-problem?) and I see there are JS-errors due to addthis. These errors are very likely to be the reason why Disqus isn’t working when AO is active; as all JS code is aggregated, one error in the JS-file stops all execution.

    Possible solutions:
    * exclude addthis from being autoptimized (add “addthis” without the quotes to the “exclude from JS optimization” list in Autoptimize settings
    * enable the “try-catch wrapping”-option in Autoptimize settings

    Hope this helps,
    frank

    Hi,

    I tried this:

    Possible solutions:
    * exclude addthis from being autoptimized (add “addthis” without the quotes to the “exclude from JS optimization” list in Autoptimize settings
    * enable the “try-catch wrapping”-option in Autoptimize settings

    Didn’t work. Thanks anyway.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Disqus Comments’ is closed to new replies.