Support » Plugin: Price list for WooCommerce product » Displays “This folder is empty.” when there are subfolders

  • Resolved krusedulle

    (@krusedulle)


    Hi Thanks for a fantastic plugin – this is exactly what I was looking for. One small thing though. When I link to a folder that has only subfolders but no files I get the text “This folder is empty.” at the end of my list of subfolder links.

    Could this be made optional? or auto suppressed when there are subfolders (ie Folder i not completely empty). Or specify some text of own choosing?

    Otherwise an awesome plugin!

    Thanks in advance

    Krusedulle

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author dovi42

    (@dovi42)

    Dear Krusedulle!

    Thank you for your comment – you are absolutely right!
    The new version (1.15) is now available for download. It contains two amendments:
    – A “This folder is empty.” text appears only if there are no folders or files in the folder
    – A “This folder is empty.” text can be changed in the plugin settings. (If you leave it blank here, it won’t appear at all.)

    Please remember to rate the plugin!
    I recommend your my other plugins as well, in case you find something else you like!

    • This reply was modified 4 months ago by dovi42.
    Thread Starter krusedulle

    (@krusedulle)

    Whauuu Very quick feedback.

    I tried to update but got this error when updating from the plugin management page in WordPress.

    Update failed: Error thrownCall to undefined function set_option()

    Plugin Author dovi42

    (@dovi42)

    Sorry, this feature has been retained for some time. The operation of the plugin will no longer be affected.
    However, the update was successful.

    • This reply was modified 4 months ago by dovi42.
    Thread Starter krusedulle

    (@krusedulle)

    The new settings have loaded in wp-admin and I can see and save the option to display an alternative text for empty folder, but page does not show any content from the plugin anymore….

    Thread Starter krusedulle

    (@krusedulle)

    hmm seems to work on page and not another – probably something I am doing wrong my end. Super great with the lightning quick response.

    I am also looking to use your gallery from folder plugin – but also having some issues getting that to work. However right now I am struggeling through how to get WordPress errors from it to display – there doesnt seem to be any… Anyway if I keep bumbling on it I may make a post under the other plugin too.

    Thanks so much

    Thread Starter krusedulle

    (@krusedulle)

    All good again with this plug-in. I just had to re-enter the shortcode on one page.

    Cheers

    Plugin Author dovi42

    (@dovi42)

    It seems to me that this page: https://www.baunegaardsvej.net/wp/?page_id=416
    now the plugin doesn’t work at all.
    Can’t you give him a folder that has nothing in it?

    Plugin Author dovi42

    (@dovi42)

    “I am also looking to use your gallery from folder plugin …”
    You can find a more detailed description and samples of this plugin here: http://wpdemo.dovi42.hu/gallery-from-files-en/
    I’ll be happy to help if you get stuck with him.

    Hi Dovi, I appreciated your “shift ..” plugin and I hope you can bring new features as I have pointed out.
    1. Now I’m trying your “download from files” and as soon as I create a new folder in ‘settings-files-add new folder” it returns “ajax. Error” and the plugin crashes, (i’m using a localhost server).
    2.Furthermore, if I create a subfolder in wp-content via windows and then try to upload some files the result is “job process running …..” and the plugin remains blocked.
    i think there is a problem with folfer path or slug

    I point this out to you for collaboration and I believe that this plugin like the previous “Shift …” will be very useful.

    Have a nice day

    Plugin Author dovi42

    (@dovi42)

    I’m working on this plugin. 🙂
    1. I apologize! I once updated and did not notice this error. I’ve already fixed it. However, I have to wait a bit for the update because I have thoroughly reworked the plugin and although I am already done testing it, I still have to rework the documentation.
    2. I tried and I can’t reproduce the error. Two cases are possible: Either the bug I’ve fixed in the current reworking, I just didn’t notice, or – and I think it’s more likely – the permissions on the folder created under Windows on your server don’t allow the website to write there. (This indicates that you will not receive an error message – at least as with the previous error.)
    Please give me some time to update the documentation and then try the new version again!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.