WordPress.org

Support

Support » Plugins and Hacks » TablePress » [Resolved] Displays only one row?

[Resolved] Displays only one row?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author TobiasBg

    @tobiasbg

    Hi,

    thanks for your post, and sorry for the trouble.

    Are some of the rows on the “Edit” screen appearing with a red background color? This means that they are hidden.
    To show them again, just click the checkboxes on their left, and use the “Selected rows: Show” button.

    Regards,
    Tobias

    Hi Tobias thanks for the quick reply No they are all white I tried deactivating all plugins and also switching themes
    I just tried creating a dummy table and it works fine
    so I imagine it is something to do with the import function
    although it shows all the rows in the back end it doesnt show them on the front
    If this is important for you to resolve I will grant you access but guilty of your time as plugin is free

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    thanks for checking. Actually, everything is ok with the import and the backend.
    There’s however a problem with the data in the table, which I just noticed, when using the “View source” function in the browser for your page.
    The table HTML code is all there, but the browser can not interpret it properly, due to the script tag:

    <script type="text/javascript" async="" src="//assets.pinterest.com/js/pinit.js"/>

    This is a self-closing HTML tag, but that’s not support on the <script> tag. Instead, this must be written as

    <script type="text/javascript" async="" src="//assets.pinterest.com/js/pinit.js"></script>

    everywhere.
    Can you therefore please change this accordingly in all table cells?

    Regards,
    Tobias

    Ok found the issue it was in the data in the table
    was trying to use this pintterst code

    ART WLG
    <!– Please call pinit.js only once per page –>
    <script type=”text/javascript” async src=”//assets.pinterest.com/js/pinit.js”></script>

    i think something happens when its saved

    Ok crossed comments we effect changes thanks

    as they say in france “Voila”! now to just sort the size!
    http://wlg.co.nz/pinterest-wall/

    Plugin Author TobiasBg

    @tobiasbg

    Hi,

    yes, looks like something automatically altered that code, I’m not sure what, though. Good to hear that it’s working now!
    By the way: According to the HTML comment

    <!-- Please call pinit.js only once per page -->

    you could remove the <script tag from all cells and maybe just put it below the table Shortcode on the page, once.

    Best wishes,
    Tobias

    P.S.: In case you haven’t, please rate TablePress here in the plugin directory. Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Displays only one row?’ is closed to new replies.
Skip to toolbar