WordPress.org

Forums

TablePress
[resolved] Displays only one row? (8 posts)

  1. gnfb
    Member
    Posted 2 years ago #

    http://wlg.co.nz/pinterest-wall/
    what have i not ticked or clicked as this table has 20 rows and only displays one

    https://wordpress.org/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    Are some of the rows on the "Edit" screen appearing with a red background color? This means that they are hidden.
    To show them again, just click the checkboxes on their left, and use the "Selected rows: Show" button.

    Regards,
    Tobias

  3. gnfb
    Member
    Posted 2 years ago #

    Hi Tobias thanks for the quick reply No they are all white I tried deactivating all plugins and also switching themes
    I just tried creating a dummy table and it works fine
    so I imagine it is something to do with the import function
    although it shows all the rows in the back end it doesnt show them on the front
    If this is important for you to resolve I will grant you access but guilty of your time as plugin is free

  4. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    thanks for checking. Actually, everything is ok with the import and the backend.
    There's however a problem with the data in the table, which I just noticed, when using the "View source" function in the browser for your page.
    The table HTML code is all there, but the browser can not interpret it properly, due to the script tag:

    <script type="text/javascript" async="" src="//assets.pinterest.com/js/pinit.js"/>

    This is a self-closing HTML tag, but that's not support on the <script> tag. Instead, this must be written as

    <script type="text/javascript" async="" src="//assets.pinterest.com/js/pinit.js"></script>

    everywhere.
    Can you therefore please change this accordingly in all table cells?

    Regards,
    Tobias

  5. gnfb
    Member
    Posted 2 years ago #

    Ok found the issue it was in the data in the table
    was trying to use this pintterst code

    ART WLG
    <!-- Please call pinit.js only once per page -->
    <script type="text/javascript" async src="//assets.pinterest.com/js/pinit.js"></script>

    i think something happens when its saved

  6. gnfb
    Member
    Posted 2 years ago #

    Ok crossed comments we effect changes thanks

  7. gnfb
    Member
    Posted 2 years ago #

    as they say in france "Voila"! now to just sort the size!
    http://wlg.co.nz/pinterest-wall/

  8. TobiasBg
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    yes, looks like something automatically altered that code, I'm not sure what, though. Good to hear that it's working now!
    By the way: According to the HTML comment

    <!-- Please call pinit.js only once per page -->

    you could remove the <script tag from all cells and maybe just put it below the table Shortcode on the page, once.

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • TablePress
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.