WordPress.org

Forums

Google Calendar Events
[resolved] Displaying that there are no events when there ARE events (7 posts)

  1. Jackie Blake
    Member
    Posted 2 years ago #

    I am using two Google Calendar feeds. One is on an Events page that shows all events with detailed information. The second feed is in the header banner and only shows one event.

    I've had the header banner which is showing one event, display a message that "there are no events to display" when there are events in the calendar and that display fine on the Events page. To fix the header banner, I change the number of events from one to two. Then the next day the feed is displayed correctly and I have to switch it back to one event. I think what happens is that it isn't displaying the first event because when I switch the event display to two, it shows the second event in the list.

    I've had this issue happen twice - once about 6 months ago and once a few days ago.

    I have Google Calendar feeds on two client websites. The sites are almost identical, the feeds are being used exactly the same way and this issue happens at the same time on both sites.

    Here are the urls - the banners are working correctly now.
    http://northgateliquors.com/
    http://toptenliquors.com/

    Does anyone have any ideas? It hasn't happen often but I don't like getting a call from my client saying that the site isn't working.

    Thank you!

    http://wordpress.org/extend/plugins/google-calendar-events/

  2. Ross Hanney
    Member
    Plugin Contributor

    Posted 2 years ago #

    Hi Jackie,

    What do you have the "Retrieve events from" option set to for each feed?

  3. Jackie Blake
    Member
    Posted 2 years ago #

    Hi Ross -

    Thanks for your help! I have "Retrieve events from" set to "now" and "0".

  4. Ross Hanney
    Member
    Plugin Contributor

    Posted 2 years ago #

    You mention that you have the header area set to display one event. Is this via the "Maximum number of events to retrieve" option (in the feed settings), or the max parameter of the [google-calendar-events] shortcode?

    I'd recommend that you set the "Maximum number of events to retrieve" option to more than one (say five), and then use the max parameter to display only one event, like this:

    [google-calendar-events max="1"]

    I think that should probably prevent the "There are no events..." issue.

  5. Jackie Blake
    Member
    Posted 2 years ago #

    Thank you for the suggestion! I have the calendar down until after the holidays so I'll have to wait a month before I try it out.

  6. Jackie Blake
    Member
    Posted 2 years ago #

    I added this code about a month ago and it's working great. Thanks again!

  7. Ross Hanney
    Member
    Plugin Contributor

    Posted 2 years ago #

    Great! Thanks for reporting back.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Calendar Events
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic