Support » Fixing WordPress » Displaying Korean Characters

  • Resolved dhobeika


    I exported the content from a website – — and imported it to where we are setting up a new a wordpress installation on a remote server at

    The site contains Korean characters and works fine on the hosted site but does not display properly on the new remotely hosted installation.

    The website is set to utf-8 encoding. Is there something I am missing? From what I have read, wordpress should be able to display these characters correctly.

Viewing 9 replies - 1 through 9 (of 9 total)
  • This is how you header looks like:

    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    You have declared the charset two times, try to remove the first one and leave the second (longer) one. They could be interfering.

    Your first link does not have it twice, this meta tag is a tag which emulates the header, that’s why it should always be the first thing in the head tags, and there should be nothing that could interfere with it.

    I only added the 2nd line temporarily as I read it might work on another thread. You must have viewed it while I had both lines, I removed it a second later. I have tried both and it doesn’t work.

    I also tried this and couldn’t get it to work…

    Any other ideas?

    Ok I’ve just looked into my own WordPress theme source code, have you tried removing the longer one and just leaving the shorter one, because that’s what I have too?

    <meta charset="UTF-8" />

    It must be a WordPress specific thing. Try setting the shorter meta tag, and then go in the WordPress account settings to Settings -> Reading and set “Encoding for pages and feeds” to UTF-8.

    And then try posting a new Korean text, because I think the older ones won’t change since even the source code is showcasing question marks. Every time you change a setting you’d have to post a new Korean post to really make sure if the setting change takes effect. I once had a charset problem myself and I solved it with this described method.

    I tried all of that. Still not working 🙁

    If there a plugin that might be able to help the cause?

    One thing I see missing in your source code is the DOCTYPE I have:

    <!DOCTYPE html>

    above the html tag. The doctype gives information about the document to the browser, though I don’t know how much it would affect the charset when it’s missing.

    That’s the only other hint that I can give you other than that I can’t see anything wrong from here.

    I don’t think that a plugin would solve this, this is a WordPress related issue, some type of setting is switching the charset to something else (probably the default limited ISO charset).

    I have a WordPress theme on my local server with only the default plugins installed and no additional plugins, and I’ve just tried posting a Korean text and it showed up without any problems.

    Since you said you have imported the content to your hosting server, I’m guessing you must have imported it into a MySQL database right? In that sense this can also be a database related issue.

    Please look into your MySQL database in your wordpress table and make sure that your collation is set to utf8_general_ci if you have set it to something else it will – as well – not work.

    p.s. Don’t forget to post a new post in your blog once you have switched the database setting.

    I already have the <!DOCTYPE html> in my header above the html tag.. not sure why you can’t see it? It’s in my header.php file and I also see it when I view the page source through my firefox browser.

    In any case, I checked the MySQL database and it’s set to utf8_general_ci

    In terms of the import, I installed a completely new version of wordpress onto our remote server, then went to the website and exported all the entries and pages into an XML file. Then I imported that file into the new wordpress installation.

    I have tried creating new posts to see if it was just an issue with the imported posts, and I still can’t get it to work.

    I really don’t know what else to do. Thanks for your help, hopefully someone else might know what to do since I gotta get this working.

    As a follow up, I have tried posting Korean characters on several other wordpress websites I have. It worked fine on a wordpress site I have on bluehost as well as one on godaddy.

    The site we are having the issues with is on Is there any chance this has something to do with it?

    I even tried installing a 2nd new wordpress installation on the dynadot server without importing any content and tried posting Korean characters and it still didn’t work. I even tried the theme that worked fine on my other site. Just trying to figure out what variables might be causing the problem.

    Are you doing the installation yourself, or using one of their tools? If using one of their tools… don’t use it. Try doing a manual installation and see if it then works.

    The default charset of the database may also be something that won’t support those characters. You may want to check/change the charset on your database, as well as on each of the individual tables and see if that helps.

    Thanks to everyone for the suggestions. In the end, we just switched to Bluehost since it worked fine on there with another site and we troubleshot everything we could think of. It is working fine now that we have the website hosted on bluehost.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Displaying Korean Characters’ is closed to new replies.