Support » Plugin: Jetpack by WordPress.com » Display WordPress Posts (Jetpack) not updating…

  • Resolved Walter

    (@boomsma)


    I’m thoroughly confused about where to post this… was asked not to add it to an existing thread by a mod… did that, then was asked to repost it in this subforum. Please understand it was/is not my intent to post more than once.

    The site using the widget is http://abbotvillagepress.com, trying to display posts from http://wboomsma.com. When first installed it listed the most recent posts… but that hasn’t changed since and I’ve added posts to wboomsma.com. I am using very few of the other Jetpack Widgets (Facebook Like, Blog subscriptions) as this is a relatively new site that I’m just starting.

    I’ve also removed and then added the widget back. It is still showing the old posts even though I’ve added several new posts to wboomsma.com.

    http://wordpress.org/plugins/jetpack/

Viewing 15 replies - 1 through 15 (of 25 total)
  • Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    I’m thoroughly confused about where to post this

    No idea what’s confusing… Posting in the dedicated sub forum for any plugin in theme is always the best place to do that. You were provided that link to post here twice and I’m glad you posted here now. 😉

    was asked not to add it to an existing thread by a mod

    Yes and that mod did right. Your problem deserves it’s own topic and interrupting someone else’s is considered rude.

    The site using the widget is http://abbotvillagepress.com, trying to display posts from http://wboomsma.com. When first installed it listed the most recent posts… but that hasn’t changed since and I’ve added posts to wboomsma.com

    Which Jetpack widget are you trying to use? I mean when you go to the widgets page on http://abbotvillagepress.com what’s the label on the widget? That may make it easier to troubleshoot your problem.

    Your problem deserves it’s own topic and interrupting someone else’s is considered rude

    Understood… but as I explained in my post on that thread I was having what seemed to be exactly the same problem as the original poster of that thread. I had no intention of being rude. It appeared the original poster had stopped responding to the suggestions and questions–I was willing to.

    The widget is the one give in the subject line: “Display WordPress Posts (Jetpack)” It is the one designed to show recent posts from a different WordPress site. On http://abbotvillagepress.com it is in the side bar with the heading “Recent Posts: Brain Leaks and Musings.”

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    I tested the widget on a test site of mine, and it seems to be working properly:
    http://i.wpne.ws/TAqx

    Do you use a caching service or plugin on your site? If so, could you try to deactivate it or clear your plugin cache, and let me know if it helps and if the widget gets refreshed?

    If that doesn’t help, could you try to remove the widget, and then add it again? Do new posts get added?

    Thanks!

    Thanks…

    I deactivated WP Super Cache–this had no effect–just kept seeing those same posts. I had already removed and added the widget with no effect.

    I tried removing the widget while WP Super Cache was deactivated and that resulted in the message “unable to load blog data at this time.”

    I reactivated WP Super Cache and still see the message “unable to load blog data at this time.”

    So these steps seem to have taken me from seeing an unchanging list of posts to seeing the error message.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    Alright. We’re making progress. I still can’t reproduce the problem on my end, but that error message gives us a better idea of the problem on your site.

    Could you make a screenshot of your current widget settings, and post it here? You can use a service like http://snag.gy/ to share your screenshot with us.

    I assumed you meant the widget itself… I had to reinstall it to do so… now it is back to showing the older posts and not the error message. But I also noticed something interesting this time… in the side bar, this widget appears within another widget! You should be able to see what I mean by visiting the site http://abbotvillagepress.com.

    http://snag.gy/ap8Kx.jpg

    Just noticed I said that backwards… the next widget appears within the border of this widget… hope that was the correct way to post the screen shot.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    Thanks for the extra details. I’ve asked one of our developers to have a closer look at this, and I’ll get back to you as soon as I have some news.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    We fixed the issue in this commit. The fix will be included in a future Jetpack release.

    Just received and completed the Jetpack update… then uninstalled and reinstalled the widget. This fixed the problem of the widget appearing within the border of the previous widget, but it is still not updating to the most recent posts.

    This might end up being re-post as my earlier one seems to have disappeared. (Now it has appeared, but I don’t know how to delete it… sorry for the double post.)

    I received and ran the Jetpack update, then uninstalled and reinstalled the widget.

    This appears to have resolved the issue of the widget appearing within another, but the post list is still not updating–it remains the same list it was a month ago.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    This might end up being re-post as my earlier one seems to have disappeared.

    Spam queue. It happens. *Drinks more coffee*

    You can’t delete your posts but you can always add another post explaining (as you have).

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    the post list is still not updating–it remains the same list it was a month ago.

    Sorry about that. It seems the old widget status is still cached in your WordPress installation.

    Could you try to deactivate and delete the Jetpack plugin, and then reinstall the plugin from scratch? That should delete your old settings and thus fix the problem.

    I deactivated and deleted the Jetpack plugin… and reinstalled from scratch. No change, the old posts are still showing.

    So I decided to try removing the widget, then adding it back.

    It STILL shows the old posts.

    I deactivated the WP Super Cache Plugin.

    It STILL shows the old posts.

    Plugin Author Jeremy Herve

    (@jeherve)

    Jetpack Mechanic

    I’m sorry to hear that. I added a Display Posts widget back to my test site yesterday, polling from wboomsma.com, and it seems to work properly on my end. I’m not sure what’s going on on your site.

    Could you try to add a new Display Posts widget, polling posts from a different site, like WPTavern.com? Do you experience similar issues?

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Display WordPress Posts (Jetpack) not updating…’ is closed to new replies.