Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author miunosoft

    (@miunosoft)

    Hi,

    Have you set up the API keys? If not, go to Dashboard -> Amazon Auto Links -> Settings and enter your API keys. If invalid keys are given, an error message will be shown when you press the Connect button.

    If you see an error there, post the error message.

    Thread Starter Charbel

    (@charbel81)

    The same data as in Associates Link Builder or?

    Plugin Author miunosoft

    (@miunosoft)

    Hi,

    I’m unable to comprehend what you are trying to say. Please follow the advice in the initial reply.

    Thread Starter Charbel

    (@charbel81)

    The same Api Key as in Associates Link Builder or? As a question to your first answer.

    Plugin Author miunosoft

    (@miunosoft)

    Sorry, I cannot comprehend what you mean.

    Maybe, are you trying to say that you entered the same API keys used for Amazon Associates Link Builder?

    Anyway, go to Dashboard -> Amazon Auto Links -> Settings. Tell me what status you see there. Is it Disconnected or Connected?

    Thread Starter Charbel

    (@charbel81)

    Yes, that is exactly what I mean.

    Dashboard -> Amazon Auto Links -> Settings. Tell me what status you see there. Is it Disconnected or Connected?

    This message appears to me: https://ibb.co/MMyQN1z

    Or Sometimes I get this message: https://ibb.co/Fhtf09S

    Message always changes when I click on connect. Sometimes there is even connected🤔

    Regards Charbel

    Plugin Author miunosoft

    (@miunosoft)

    Hi,

    So you get different error messages and it connects sometimes. It is indeed odd.

    The error, 429: Too Many Requests, can be seen when you hit the daily API rate limit. Or it can also be triggered by setting the wrong locale. Make sure you enter the correct keys, locale, and the Associates ID. If you type one of them incorrectly, it can cause an error.

    I’d suggest you test your keys on ScratchPad. Make sure you don’t get an error there.

    Also, if you are running multiple sites using the same API keys, it could be the reason to result in exceeding the rate limit. In that case, I’d suggest you try to reduce the number of API calls. One way to avoid reaching the API rate limit is to set a longer cache duration for each unit.

    By the way, v4 (still in development) comes with a new unit type called Feed units. With them, you can import external unit data into another site so that it helps to reduce a number of API calls.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘display problems’ is closed to new replies.