Support » Plugin: Content Blocks (Custom Post Widget) » display Problems

  • Resolved vizaldiggard

    (@vizaldiggard)


    Hi There, I use your fantastic plugin on a number of my websites, I have just started adding another plugin to my sites (called wp product reviews lite) this puts a detailed review summary box into my posts when i write a product review.

    The trouble is that this review box also displays in each and every content block that i use (in both the main article body and in the side bars and I cannot see how to stop it. On one page it showed up 4 times and made the site look terrible.

    Any ideas on how i can stop this??

    Thanks

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Johan van der Wijk

    (@vanderwijk)

    Hi, this is a known issue that you can prevent by checking the ‘Do not apply content filters’ checkbox on your content block widget, or if you use the shortcode to add suppress_filters=true to the shortcode.

    Thanks Johan.. I will try that out

    Johan.. thats cured the problem with the side bar, but am a bit confused when i use the content block shortcode in posts.. as an example where and how would i add the shortcode that you mentioned above to this shortcode from my site: [content_block slug=mid-content-link-muscles]

    • This reply was modified 6 months, 1 week ago by  vizaldiggard.
    Plugin Author Johan van der Wijk

    (@vanderwijk)

    You can try this: [content_block slug=mid-content-link-muscles suppress_filters=true]

    Thanks Johan I just tried it – that shortcode doesn’t work….:(

    • This reply was modified 6 months, 1 week ago by  vizaldiggard.
    • This reply was modified 6 months, 1 week ago by  vizaldiggard.
    Plugin Author Johan van der Wijk

    (@vanderwijk)

    Try using the post ID of the content block you want to add, so like this:

    [content_block id=26576 suppress_filters=true]

    Change the number to the required post ID, you can find this on the content block edit screen or when you insert it using the ‘Add content block’ button above the editor.

    Hi Johan…. Its not working….. sorry to be a pain, its just so frustrating
    Paul

    Plugin Author Johan van der Wijk

    (@vanderwijk)

    I’m sorry to hear that Paul. Unfortunately I am a out of suggestions now, you could try switching on debug to see if there are any errors.

    Ok Johan, Many Thanks for trying to help….Best wishes Paul

    Jakob Smith

    (@diakrisis)

    Hi Johan and Paul

    I just had a similar problem and found that Johan in another thread suggests this:

    You can do that by adding this to your shortcode:

    suppress_content_filters=”yes”

    See https://wordpress.org/support/topic/add-option-to-not-apply-content-filters-in-shortcode/?replies=4 for more information on this.

    So, in my case, the shortcode is:

    do_shortcode('[content_block id="3405" suppress_content_filters="yes"]');

    And that works in my case.

    The do_shortcode() is because I’m executing the content block in PHP code.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.