Support » Fixing WordPress » Display posts AND pages in featured content slider oxygen

  • Hi!

    I´m using the Oxygen theme for my website. This theme includes a featured content slider. The only issue I have with this slider that it will only show posts, and not pages. I also want to show some of my pages in my featured content slider. Should I adjust the .php file (how)? Or find a plugin that show both pages and posts?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Hi,

    create a new page (As example: _HOME_) and set the attributes template to “frontpage”.
    Go to Settings -> Reading and set the start page to static. -> Choose _HOME_

    Now every Post with the Location “Featured” will be shown in the slider!


    Hi , Can anybody please help to explain how to set up a slider? For some reason, I could not activate that.

    Thank you in advance!

    Same here as PloyP – I can’t get the slider at the top to show up (even when I make many posts “featured”) I also can’t get the secondary no-image display to show up. Help!

    I just installed Oxygen and, like some users, I had trouble to make the slider work.

    Well, after some research I got the slider working!

    Here is what you need to do:

    – Create posts, selecting a featured image for each one, and setting Featured as Location (last box in the right side);
    – Create a page and set Template as “Front Page”;
    – In the Settings/Reading set the front page to display as static page, selecting the page you created in the Front page combobox.

    Hope this help.

    Thanks, Jcarrio. You helped me too.

    I’m trying to a create a blog with the Oxygen Theme, but I have the same problem as you : the slider doesn’t work. I’ve done exactly the same, but nothing appears. Do you think it could be a problem with the images size ? If someone who uses Oxygen could help me, it would be great ! (And please apologize my ugly english !)

    Thanks, Jcarrio! That helped!

    Does anyone know how to make static pages show up in the slider?

    I seem to remember that the featured image for a post that’s supposed to show in the slider, must be at least 950px wide (not 100% certain about the number, can’t find the document now), otherwise it wouldn’t show. That’s consistent with my trial and error experiment with the version.
    (Update, I was probably reading this, which says 750px. Just note that it refers to the version)

    Now after exporting to self-hosted, I’ve got it to work again using what jcarrio described above, but I suspect that users following that and still not getting the slider, might be using featured images that are too small. Thought it was worth mentioning.

    That still doesn’t solve the original question, about how to get pages to show up (which is what got me to this thread). I’ll keep trying and post back if I figure out how.

    I registered at Devpress (which I recommend, they’re very quick to reply to support questions).
    In short, I found out that by design the ‘featured content slider’ must point to posts, not pages. The alternative was to replace it, and it wasn’t overly complicated.

    The solution I used doesn’t feature the thumbnails, so if you need them, you would have to find a different slider plugin.

    I used Devpress’ Sliders plugin (which I think is for subscribers only, others sliders might work as well). A good thing about ‘Sliders’ is that its default styling matches Oxygen pretty well. Configuring the plugin is straightforward, but in order to make it work with the theme, you will need to create a new page-template-front.php and add to your child theme (I assume one would be working on a child theme). There you need to replace one line of php code; <?php get_template_part( 'featured-content' ); // Loads the featured-content.php template. ?>, and (if you’re using ‘Sliders’), replace it with <?php echo do_shortcode( '[sliders id="xx"]' ); ?> (where xx is the id number of your slider). If using a different slider plugin, I’m sure the documentation describes which code to use.

    To bring it into the slot of the original slider, you’ll need to adjust the css. I can’t remember just how I did it, would have to look it up.

    I have my slider working fine on posts lits like jcarrio outlined but I came here looking for a way to get the feature image PAGES to also end up in the slider with the posts. Anyone with success accomplishing this? I’d like to avoid turning all planned feature pages to posts if possible.

    I asked the designer about this at one point, and he told me the ‘featured-content-slider’ can NOT display pages. I didn’t attempt to hack it, but changed the plan (which I described in the reply above yours).



    If anyone is still having trouble let me know. I spent a good deal of time to figure out how it is all linked together and to get the photos to show up on the front-slider just like the demo shows.



    This is semi-related to this thread. I am having a problem with this slider in the Mystique Theme. My intention is to have the slider be in a sticky post/aside under my header. I did this and when I publish the slider live it shows where I want it, AND above my header image. I don’t want it to show above my header image.

    You can visit and you’ll see that I have a coupon slider in the center below my nav bar (which is in a post – sticky) I intend to replace that slider with this one. But, when I activate this slider it drops my header image (the whole top of the page) down and puts a slider up there (left-aligned) as well as in the post-sticky where the coupon slider currently is.

    How do I get it to stop putting a slider at the top of my website?

    If anyone has any insight it would be helpful!




    Been following guidelines from several previous posts, and am still experiencing problems getting the slider to display on the front page.

    I followed the following:
    – Create posts, selecting a featured image for each one, and setting Featured as Location (last box in the right side)**”setting featured as location is not an option available to me”;
    – Create a page and set Template as “Front Page”; – did this
    – In the Settings/Reading set the front page to display as static page, selecting the page you created in the Front page combobox. – did this.

    What am I missing?

    Any suggestions are most welcome:p)



    Upon trying something new out, I figured it out. For those of you that are still having problems, here are the guidelines on how to implement the slide show slider on the front page:

    1. All your photos MUST be 750 px wide. Or it wont work.
    2. Create a new post, title it what you want it to appear as, on the slider.
    3. Add a “featured image”(remember it must be 750px wide). This option is located on the bottom right side bar.
    3. Edit your “visibility:Public” by adding a check box next to “Stick this post to the front page.” This option is located in the right side bar, on top.
    4. Save the post – and that’s it!

    Create all posts you want to appear in the slider by following these above directions, and they will appear as a gallery below the slider, on the front page and show up in the slideshow – just like on the demo template.

    Hope this helps!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Display posts AND pages in featured content slider oxygen’ is closed to new replies.