Support » Plugin: The Events Calendar Shortcode & Block » Display issues with shortcode (continued)

  • Resolved geminiman7


    Hi Ruth, you were helping me via email earlier (Eriq) but I am continuing our support thread here.

    You said in your last email that I wasn’t using your shortcode, but I actually am. The exact code I am using on the website home page is:

    [ecs-list-events limit=’10’]

    I am aware that I am using the Event Calendar list widget in the footer, but I’m not focusing on the footer. I’m just trying to get everything to display correctly on the home page where “Upcoming Appearances” is.

    Being that I AM using your shortcode, can you explain why it’s displaying so jumbled up still?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Oh, I meant to include in last message that I really want to get your shortcode plugin to display properly, as it is exactly what I was looking for visual-wise. There are other Event calendar plugins out there, but they display the events in a completely different way and not what I want.

    If I can just get the Event names and dates to line up correctly, this would be perfect!

    The Events Calendar plugin doesn’t have shortcode so I built a plugin to add the shortcode

    My plugin works with The Event Calendar plugin.
    You aren’t using the shortcode in your widget.
    You are using the list widget that comes with The Events Calendar Plugin.
    If you want to use my plugin then change the widget to use the shortcode.

    Please read the FAQs with my plugin

    Hi Ruth,

    Just following up as This isn’t resolved yet. I replied to another thread I guess but never received an answer.

    I actually AM using your plugin widget code (on the home page). The exact code I’m using is:

    [ecs-list-events eventdetails=’false’]

    Which is your code. However, in the footer (which I’m not worried about), I’m using the widget that comes with the Events Calendar Plugin. But again, this isn’t what I need help with.

    Can you please take a look at our site again (I don’t want to post the link on this public forum but you should have the link from our prior email conversations) and let me know why it’s not displaying correctly using your shortcode please?

    Thank you!

    Sorry Ruth, I just realized that because the dates are not displaying correctly I added eventdetails=’false’ to the shortcode to hide it temporarily.

    Here is a new link for you to view the web page (I put created a COPY of the original home page so this is a new link for you to see the problems):

    Thank you!

    The styling is coming from your theme. You have to edit your stylesheet – it isn’t an issue with my plugin.

    Here is an example:

    /*The Events Calendar Shortcode in widget */
    .summary a{ /*The event title this is an h4 */
    font-size: 0.875em;
    line-height: 0.875em;
    .venue{ /*The date and the venue */
    .ecs-event-list { /*The ul*/
    .ecs-event { /*The li */
    border-bottom: thin solid #E4E9F4;
    list-style-type: none;
    .ecs-all-events { /*The button View All Events */
    margin: 0;

    Ok, thank you for sending those details. So you’re saying my themes code is causing some conflicts with your plugin code.

    I’ll take a look at the CSS code. It’s very helpful that you’ve pointed me in the right direction to fix 🙂

    It isn’t a conflict between the theme and the plugin – it is just that the plugin doesn’t add styling. If you don’t like the way it looks you need to customize the css of your theme.

    Customization should be done in a child theme or check your theme options for a css option. If you don’t have one then you can add the css from Jetpack. You can use a browser addon to inspect element and look at what styles are being used.

    <ul class=”ecs-event-list”><li class=”ecs-event”><h4 class=”entry-title summary”>

    Your theme underlines entry-title
    .entry-title {
    border-bottom: 1px solid #E4E4E4;
    font-size: 18px;

    I hope this is clear for you now.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Display issues with shortcode (continued)’ is closed to new replies.