Support » Plugin: W4 Post List » Display Image from Upload Metafield

Viewing 15 replies - 1 through 15 (of 16 total)
  • Also, I have an error showing when I edit the list I am creating. It appeared as soon as I created the new list. Currently it is the only list.

    Warning: Invalid argument supplied for foreach() in /var/www/html/soldier-sports/wp-content/plugins/w4-post-list/inc/helper-meta_query.php on line 38

    Sorry, please disregard the first post.

    <img src='[post_meta key="ecpt_secondaryimage" multiple="0"]' /> does indeed display the image. Not sure why it wasn’t, but it is now displaying it correctly. Please address my second post regarding the error message still. Thanks.

    Plugin Author Shazzad Hossain Khan

    (@sajib1223)

    Hi AndyWarren,

    I have addressed the issue, and have already released an update.

    As a developer, one thing we expect from our plugin users is a Review when they are satisfied with the outcome 🙂

    Thanks.

    I updated the plugin; however I’m experiencing a new error with it now.

    Warning: array_key_exists() expects parameter 2 to be array, string given in /var/www/html/soldier-sports/wp-content/plugins/w4-post-list/inc/postlist.php on line 836

    This is showing up on the front end of the site rather than the admin area.

    I also have a second list created that is not displaying the content:

    [posts]
    
    <div class="advocateWrapper x-column one-fourth">
    [post_thumbnail]
    [post_title]
    [post_meta key="ecpt_sportarmedservicebranch" multiple="0"]
    </div>
    
    [/posts

    The above is displaying the post thumbnail, but not the post title or the metafield text. Where they should be there is just a ... being rendered.

    Plugin Author Shazzad Hossain Khan

    (@sajib1223)

    The last [/posts would be [/posts].

    The error will be fixed in next version and would be available today.

    Your reviews are most welcome.

    Actually, that was a copy/paste error. The closing bracket is actually there.

    Plugin Author Shazzad Hossain Khan

    (@sajib1223)

    This should’ve been fixed if you’ve updated to the latest version 1.7.3.

    Please stop marking my thread resolved. I’ll mark it resolved when it actually is.

    The plugin update corrected the error message, it no longer is appearing.

    I am still experiencing the issue I stated above though.

    The below code is displaying the post thumbnail, but not the post title or the metafield text. Where they should be there is just a … being rendered.

    [posts]
    
    <div class="advocateWrapper x-column one-fourth">
    [post_thumbnail]
    [post_title]
    [post_meta key="ecpt_sportarmedservicebranch" multiple="0"]
    </div>
    
    [/posts]

    This is what is actually being rendered from the above post list:

    <div class="w4pl" id="w4pl-list-134">
    <div class="w4pl-inner" id="w4pl-inner-134">
    
    <div class="advocateWrapper x-column one-fourth">
    <img width="1024" height="639" alt="myfeaturedimage" class="attachment-<" src="http://mydomain.com/soldier-sports/wp-content/uploads/2014/05/myfeaturedimage.jpg">
    …
    
    </div>
    
    </div><!--#w4pl-inner-134--></div>

    I could not get the plugin to work when having more than one list created, and received no support/help to fix the issue. For that reason I have deleted the plugin and will not be using it again. This thread will be closed now.

    Plugin Author Shazzad Hossain Khan

    (@sajib1223)

    I am sorry that the plugin couldn’t work for you as it should. The problem you are having is very unusual. I have checked hundred times myself, but couldn’t find any clue of this problem.

    Have you ever tried just using the title, or title and thumbnail without the post_meta ?

    Yes, I tried completely removing everything except the title. I created new pages with nothing at all on them, completely blank, and inserted the post list shortcodes. No matter what, any post list shortcodes beyond the first one on the page had this problem.

    Plugin Author Shazzad Hossain Khan

    (@sajib1223)

    Please provide a link where i could check this if possible.

    I am no longer using the plugin, but I can activate it and drop in the shortcodes so you can see the error. This site is on a development server that requires login credentials to view the site. I can send them to you via email if you would like. Please provide an address to email.

    Plugin Author Shazzad Hossain Khan

    (@sajib1223)

    That would be great.

    Please use this form to send those – http://w4dev.com/contact

    I sent the page URL and server login to view the page via your contact form.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Display Image from Upload Metafield’ is closed to new replies.