Support » Fixing WordPress » Display comments on homepage

  • Hi,

    I want help urgently on something which is not working at all. I am displaying only one latest post on my homepage and I want to display it’s comment box for it.

    As you know, WordPress by default does not display the comment box on homepage, you can only comment if you click on the post link. So, I made some research on how to do it but unfortunately, it is not working.

    I tried to add this in the index.php file of the Theme at the end before the closing </div> tag:

    <?php $withcomments = “1”; comments_template(); ?>

    However, this is not working at all. I mean the comment box is not displaying on the homepage.

    Can someone help me please here?

    Thank you

Viewing 7 replies - 1 through 7 (of 7 total)
  • try:

    <?php global $withcomments; $withcomments = true; comments_template(); ?>

    thank it works well now. i have another question:

    Right now, I am displaying only 1 post on front page. I set “1” in Reading in Settings.

    However, it seems in a category page which I have, it is displaying only 1 post there as well. Do you know how I can display at least 10 posts in a category page and not 1? I want only the homepage to have 1 post.

    Thank you

    review
    https://codex.wordpress.org/Plugin_API/Action_Reference/pre_get_posts

    example code (to be added into functions.php of your theme or ideally of a child theme):

    function category_archives_posts_per_page($query) {
      if ( !is_admin() && $query->is_main_query() ) {
        if ( $query->is_category ) {
          $query->set( 'posts_per_page', 10 );
        }
      }
    }
    
    add_action('pre_get_posts','category_archives_posts_per_page');

    this works well except it is displaying full contents instead of excerpt.

    do you know how to make it appear excerpt?

    normally on homepage, i set the content to full. but i dont want this on the post on category… is it something i must modify functions.php?

    do you know how to make it appear excerpt?

    is it something i must modify functions.php?

    this might depend on your theme and the way your theme uses theme options. (hint: http://codex.wordpress.org/Forum_Welcome#Include_as_Much_Information_as_Possible )

    generally, if your theme has it, edit category.php (otherwise check for archive.php or index.php and use a cinditional statement), and change ‘the_content()’ to ‘the_excerpt()’ (you might need to follow any ‘get_template_part()’ hints to find what template you need to edit…

    In my content.php I modified the bold part from “excerpt” to “content”:

    <?php if( !is_single() ): // If blog loop, show excerpt content ?>
    
    <?php the_<strong>content</strong>(); ?>
    
    <?php else: // Else if single post, show full content ?>
    
    <?php the_content( __( 'Continue reading <span class="meta-nav">&rarr;</span>', 'agama' ) ); ?>
    
    <?php endif; ?>

    On the homepage, the post id displaying full which is good but on the Category page listing, I want it excerpt, but it is displaying full there as well.

    <?php if( !is_single() ): // If blog loop, show excerpt content ?>

    <?php the_content(); ?>

    <?php else: // Else if single post, show full content ?>

    <?php the_content( __( ‘Continue reading <span class=”meta-nav”>→</span>’, ‘agama’ ) ); ?>

    <?php endif; ?>

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Display comments on homepage’ is closed to new replies.