Support » Plugin: bbp buddypress profile information » Display breaks when field is multi-select

  • Resolved elliesatt

    (@zee300)


    Hi there – the plugin works well as far as I can tell, except for one instance when it is trying to display a field that is multi-select.

    This is what shows up: https://imgur.com/fWR4WKb

    So instead of showing just Profile Field, it shows a:1:{i:0;s:11:"Profile Field";}.

    Is there anything we can do to remove the extra characters on either side? Thanks!

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Robin W

    (@robin-w)

    so where is this showing ?

    Thread Starter elliesatt

    (@zee300)

    I’ve re-enabled it, you can see it here. Please excuse the messy CSS!

    Thread Starter elliesatt

    (@zee300)

    Also, the fields don’t seem to show in the first reply (i.e. the original thread starter’s ‘reply’). Is that intended?

    Thread Starter elliesatt

    (@zee300)

    Any thoughts so far? I’m happy to change to a dropdown, but the users that already have values in their fields all have the garbled versions regardless.

    Thread Starter elliesatt

    (@zee300)

    Hi – are there any plans to look at this issue/bug? If you can let me know either way that would be great.

    Plugin Author Robin W

    (@robin-w)

    apologies, I was not getting your email updates.

    I’ll take a look on the next day or so

    Thread Starter elliesatt

    (@zee300)

    No problem. Did some database investigative work last night, and it looks like when multi-select is used, the metadata is stored as a:1:{i:0;s:11:”Profile Field”;} rather than simply Profile Field.

    So not sure if this is correctable within your plugin. I’ve simply moved to a single-select dropdown menu, and cleaned up the old metadata with some SQL find replace.

    i.e. I’m good for now, but not sure if multi-select will work with your plugin (or it’s just my site’s oddity).

    Plugin Author Robin W

    (@robin-w)

    hmmm… where is this in metadata?

    Thread Starter elliesatt

    (@zee300)

    My metadata is in bp_xprofile_data

    Plugin Author Robin W

    (@robin-w)

    ok, then this won’t work, the code works for tags held in the bbpress topic tags part, ie

    dashboard>topics>tags

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.