WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Display address missing spaces

[Resolved] Display address missing spaces

Viewing 5 replies - 1 through 5 (of 5 total)
  • I am having this same issue… spacing all runs together, including telephone number… been trying to fix in CSS but can’t seem to make the proper adjustment. Any help would be appreciated!

    Plugin Author Store Locator Plus

    @charlestonsw

    Set your CSS for those DIV IDs to width: 100% and display:inline-block.

    The CSS and themes (Pro Pack) should do this for you, however some themes take over all div formatting and can break the default CSS that is included.

    Every element of the address in the results has its own div class & ID to give more control over the results format.

    If that does not work for you the Enhanced Results premium add-on has a “results string” entry where you can create your own output format exactly as you want it:
    http://www.charlestonsw.com/support/documentation/store-locator-plus/enhanced-results-add-on/

    Set your CSS for those DIV IDs to width: 100% and display:inline-block.

    And how do we do this?

    The spacing was okay before the upgrade.

    Plugin Author Store Locator Plus

    @charlestonsw

    If you have Pro Pack you can set the CSS under General Settings or by editing your selected Pro Pack theme file (in ./css/).

    The results formatting was changed because it was too restrictive using fixed spaced table cells. This makes it nearly impossible to work with a number of new WordPress themes especially responsive themes that tend to use CSS and DIVs. That is the preferred methodology for page structures these days. Without making that change the plugin would not work for many newer themes. It also makes it very difficult for other developers or site designers to move results listings around to their liking.

    Of course with any change some of the 500,000 themes and 50,000 plugins out there will not work as well.

    If the updates don’t work with your theme/plugin mix you can always revert to the prior release here:
    http://wordpress.org/extend/plugins/store-locator-le/developers/

    In the CSS, under General Settings, I added the following:

    span.slp_result_address {
    width: 100%;
    display: inline-block;
    }

    This worked for me, thanks.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Display address missing spaces’ is closed to new replies.