Support » Fixing WordPress » Display 404 page when preview or update page, post or image

  • Dear Sir / Madam, I assisting my friend website and tried to deactive plugin’s and themes but it didn’t work. Adding new post or page won’t be any issue but update existing post or page then it display page not found.

    Can you assist my friend website with solutions asap?

    Appreciate your prompt reply.

    Thank you.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hello @hlinte3

    Hope all is well!

    Locate the .htaccess file in the site’s directory, keep a copy on your local device just in case and remove it from the site.

    From the network admin, go to Settings > Permalinks and re-save the changes. Check if this fixes 404 errors. After this, the .htaccess file will be regenerated again.

    Hope this helps!

    Cheers,
    Nastia

    Thread Starter hlinte3

    (@hlinte3)

    Dear Nastia,

    I have tried the method but it doesn’t worked at all. Kindly assist us soon.

    Thank you.

    Hi,
    I also think the problem can be in the .htaccess file. If it’s generated automatically by WordPress and you haven’t edited it, that may be the problem.
    Here is how it should looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    	# WP Maximum Execution Time Exceeded
    	<IfModule mod_php5.c>
    	
        php_value upload_max_filesize 1024M
    	php_value post_max_size 2048M
    	php_value max_input_time 3000
    
    	php_value max_execution_time 3000
    
    	</IfModule>

    It can also be a plugin. The most common plugin to do such errors is the “Slider Revolution” plugin. If you have it too, simply deactivate it and check if the website works in the correct way.

    Hope that will help!

    • This reply was modified 3 years, 2 months ago by atanas1223. Reason: Added some more details

    Hello @hlinte3

    Hope all is well!

    As atanas1223 mentioned, please try adding the default define rules into .htaccess. See the sources from here:
    https://codex.wordpress.org/htaccess

    For single WordPress site

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    For Multisite subfolder

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    If you still experience the issue, choose the option ‘Default’ in Permalinks page then save changes.

    Go to Settings > General and check the WordPress address (URL) and Blog address (URL) set correctly (no slash at the end of the URLs).

    Hope this helps!

    Cheers,
    Nastia

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Display 404 page when preview or update page, post or image’ is closed to new replies.