Support » Plugin: W4 Post List » Disfunctions with 2.1.2 – unknown

  • Hi,
    It is a long time that I had not taken care of my post-list;
    i had to do many thing for my project, I had tested W4 more than one year ago and because everything was OK, I had set all lists preparation at the end of the project.

    I have updated to 2.1.2 and tried the basic actions : modify list, create new ones.

    HELP

    I get “no sense” screens : for new :

    1- ask for title
    2- ten times : the left selection of definition items and the fist block of “list type and preset”
    3- SEO settings
    4- WP-edit for excerpt
    5- wpsso parameters for the list (I use this plugin)
    6- the right column (admin widget) as for any document

    When you click on the option “post” of first block (of the eleven) you get the “hourglass (rotating disk)” and nothing more : end : page to close

    When you try to modify any you get “error reading” and ten times :
    1- ten times the options selection : list type, post, post meta query, post date query, template, style
    2- once the panel, but if you click any of the options of the eleven you get the same
    3- the end of page as for new

    So there are three great anomalies :
    1- error reading definition
    2- ten repetitions of the block options and edition (panels of parameters) both edit and new
    3- for new first click launches the hourglass without issue

    I have not tried any update in these conditions.

    Product is not usable. I don’t understand how other users can get something else than me.

    Do you have an idea

    I have screenshots and html export (I analyze with the inspector and I go on to find something and seeking the code) for pages but cannot transmit anything here

    Trebly

    Note : as in “new” the div
    <div id="w4pl_list_options"><input .... </div>
    is repeated ten times with same id(s) it is impossible that it could functions.

    The same for the edit mode.

    • This topic was modified 2 years, 10 months ago by Trebly.
    • This topic was modified 2 years, 10 months ago by Trebly.
    • This topic was modified 2 years, 10 months ago by Trebly. Reason: add the note
Viewing 1 replies (of 1 total)
  • Hi,

    The problem is solved.
    Sorry but I had performed a bad manipulation and upload a version in which I had done some little changes (which should not change anything in the soft behavior else than allow a better execution), the reason of these changes is that when you run debug-mode (I develop extensions) and more I use the PHP and JS syntax level checker of phpstorm editor they signal a great number of obsolete or missing requested instructions into your code.
    I had, on a version of the plugin, made these changes. I was thinking to have your original version running while it was the modified one.
    For an unknown reason the changes (most declarations) are the origin of the problem.

    These modifications are (one of them) are the cause of the problem.
    Later I have added my extensions of features (“include new shortcodes” into helper-post.php) on your original version without any problem.

    If you wish to get the version which generates the failure, tell to me how to send to you this sources (all changes are with a comment).
    This can be useful because if you perform these requested and needed changes (they will be necessary) you will meet probably the same problem.

    Best regards

    Trebly

    • This reply was modified 2 years, 10 months ago by Trebly.
Viewing 1 replies (of 1 total)
  • The topic ‘Disfunctions with 2.1.2 – unknown’ is closed to new replies.