Support » Fixing WordPress » Discussion settings being overwritten on publish

  • This problem began in 2.6.5, just after I moved from one host to another. I have upgraded to 2.7, the problem continues.

    My discussion settings are defaulted to allow comments, trackbacks and pings. I have my twitter plugin set to notify twitter with new posts, as well.

    Every time I publish a post, making sure that checkboxes are checked, everything is set to allow comments, trackbacks, pings and twitter notify – the post publishes and disables EVERY checkbox. The post publishes “comments off” and I have to edit the post, check all the boxes, and resave.

    What I’d like to know is where to begin looking to fix this. Any help would be appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • This is very odd behavior.

    First, ensure that all your Settings are set to comment, trackback, and such on a global scale. And turn off the Twitter Plugin to see if that is causing the problem.

    If that changes nothing, after a browser refresh or restart, then get serious.

    I’d first start with a clean install of WordPress 2.7 (make sure you follow the manual instructions carefully after backing everything up) and turning off ALL Plugins. Activate the default WordPress Theme with no Plugins active and see if the problem still exists.

    If it still has problems, then this is a serious issue and something is very wrong.

    If it works, then start doing a process of elimination. Activate the Plugins with the Default WordPress Theme one by one. Any changes? Keep going and then activate your Theme last.

    I think that somewhere along the way you will find the problem, but it takes some time to process through and figure out what is wrong.

    I wish I could do this without having to test 40 posts on publish – my site is a full blown portfolio and blog, so troubleshooting it is going to cause a lot of problems. (Talk about annoying my feed subscribers!)

    I’m going to have to see if I can reproduce my site on another space and troubleshoot there, I guess.

    Thanks, Lorelle.

    If anyone has any other suggestions – I’m all ears.

    I’ve run a database query to force comments/trackbacks/pings open – did a test post turning off dofollow & twitter, comments were still disabled on publish.

    Still troubleshooting – but am hoping one of you techs will know what might trigger this on publish.

    Another update.

    I’ve repaired my database.

    Did a clean install of 2.7.

    Disabled ALL plugins and published a post, the comments/trackbacks/pings were all disabled on publish.



    Forum Janitor

    When you say “Did a clean install” do you mean against your old database (just replacing the web files) or a fresh, empty, database?

    Seems a bit odd.

    Which plugins have you had installed?

    What happens when you save a draft rather than publish?

    I did a clean install = deleted all old files and replaced them – using the old database.

    The same thing happens when I save as a draft and preview – the comments/pings and twitter notify boxes are unchecked.

    Since it happened without any plugins active at all – it has to be something that is triggered in the action of saving/publishing a post. I had the Disable Revisions and Autosave plugin active as well – there’s no change with or without that plugin.



    Forum Janitor

    Potentially yes, though if you are using the pre-existing database some setting could be stuck in there. I’ll take a look on my test 2.7 with those plugins.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Discussion settings being overwritten on publish’ is closed to new replies.