Support » Fixing WordPress » DISCUSSION “comment” SETTINGS ‘saved changes are not taking effect at all’

  • About the circled area in this screenshot: https://postimg.cc/4HvcbnDk

    On the wordpress dashboard

    Go to => settings => Discussions => “Other comment settings”.

    Uncheck all boxes or change anything… And then save

    You see that saved changes DO NOT take effect… i.e unchecked boxes still remains checked


    Its like this on all my wordpress sites…is this a major wordpress problem?… Ive tried two themes….same thing.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and switch to the default Twenty Nineteen theme. If the problem goes away, enable them one by one to identify the source of the problem.

    If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    i already tried that, still problem persists

    Its happening on all wordpress sites, right now … Give it a try from your end

    -changes DON’T take effect… No matter how many times you try to save,

    – im using a mobile phone btw,

    “i have also tried on my PC

    ..

    It keeps saying “settings saved”

    But the boxes i unchecked before saving… Are clearly still checked..and no change took effect at all.

    ..

    • This reply was modified 1 month, 2 weeks ago by evillizard.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Its happening on all wordpress sites, right now … Give it a try from your end

    There is no such problem on any of my sites running WordPress 5.3.

    There is also really no “from your end” in the way you mean. All WordPress sites are entirely self-contained. They are not interconnected in any way, and no one here has any more access to your site than any normal visitor.

    Now, back to the problem at hand. Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    @macmanx hello sir?…any solution yet to the problem? I am still waiting

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    @evillizard Don’t @ ping people for support. Yes, I know I just pinged you but as a moderator I am trying to educate you.

    Don’t post user IDs and login credentials. You want to change that password now. That’s not how these forums work. I archived that post.

    These are volunteer support forums. You’re a volunteer too. You’re not a customer here so trying to summon another volunteer isn’t appropriate that way here.

    Can you please try some temporary troubleshooting steps?

    • Switch to the Twenty Twenty theme
    • Deactivate all the plugins, no exceptions
    • Clear your browser’s cache and cookies

    And re-visit your site. Does the problem discussion “comment” settings problem still exist when you do that?

    //Don’t post user IDs and login credentials. You want to change that password now.//

    -alright sir, but its just a test website anyway

    ..

    //-Switch to the Twenty Twenty theme
    -Deactivate all the plugins, no exceptions
    -Clear your browser’s cache and cookies//

    Yes sir i have tried all these which is why i posted log in details to the test website for anyone to log in and check whats wrong first hand.

    Yes sir, The problem still exist when i do all those,

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Do you have trouble with other WordPress sites under this hosting provider, or just the one?

    evillizard

    (@evillizard)

    After much investigation, i figured it is only this hosting provider

    My other sites on other hosting providers work just fine and do not have this problem

    Pls how do i fix this anyway?

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    I recommend reporting the issue to this hosting provider’s support, or switching to a different hosting provider.

    Most likely, something is misconfigured in their server-level caching.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.