Support » Fixing WordPress » discussion check not appear

  • Hi, I have activated comments for new posts, but I cannot activate comments for every single post, the “allow comments” checkbox does not appear, I have checked and there is no plugin that does not show comments, what could be the problem?

    thanks

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • You could try this plugin with its troubleshoot-mode: https://wordpress.org/plugins/health-check/

    In this you disable all plugins. Please check if the checkbox in this mode appears in the posts. Activate the plugins step by step until it vanishes – than you have found the plugin which is responsible.

    • This reply was modified 9 months, 3 weeks ago by threadi.
    Thread Starter raffodesigner

    (@raffodesigner)

    thank you! but I checked and everything is ok, I tried to deactivate all the plugins but the possibility of activating comments for each single post does not appear, any other advice?

    thanks

    I would have 2 more ideas about this:

    If you use the Gutenberg editor, you can also hide the checkbox for comments there. Open the Gutenberg editor on any post. Go to the top right on the cogwheel and then on Preferences. Then under “Panels” there is a switch to show and hide individual sections. I guess that discussions are deactivated there.

    If that doesn’t solve it, please activate a WordPress standard theme, e.g. TwentyTwentyTwo, and check if the option is visible again.

    Thread Starter raffodesigner

    (@raffodesigner)

    thank you! there is no entry in gutemberg’s preferences that says discussions or comments.

    But I tried to change the theme to a wordpress default and the checkbox “allow comments” is present.

    What could it be? Has a script been created to delete them?

    thanks again

    It could be a “feature” of your previously used theme. Which theme have you used so far?

    Thread Starter raffodesigner

    (@raffodesigner)

    picostrap

    I guess you mean the theme you can download here, unfortunately it is apparently not in the official repository: https://picostrap.com/#downloads

    I have installed the 1st package from there. Without further configuration, the comment function is available normally. In the Customizer you can find an option called “Disable the WordPress comments system” (under “Global Options”) which is not set after installation. As soon as I set this, I no longer find the comment function on posts as described by you.

    So you would have to change this option in your theme settings in the customizer to be able to use comments on posts again. If you have further questions please contact the developer of this theme.

    Thread Starter raffodesigner

    (@raffodesigner)

    solve it!!!! thank you!!!!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘discussion check not appear’ is closed to new replies.