Microblog Poster
[resolved] Disconnected from wordpress when I authorize a facebook account (7 posts)

  1. centaurus
    Posted 2 years ago #


    I installed microblog poster on http://www.top-du-web.com and creates the app correctly...

    I link my facebook profile, but when I click
    "Authorize this facebook account"
    it logs me out of WordPress! (so it does not validate the link ...)

    How to do ?


  2. centaurus
    Posted 2 years ago #

    and my site is hosted by 1and1... (I feel that the problem is related to the host yet curl is enabled)

    Help :)

  3. Efficient Scripts
    Plugin Author

    Posted 2 years ago #

    please make sure you have the latest version of the plugin (1.3.4). Also if you could provide some php error because without more details I can't think of anything. This isn't a known issue we have.

  4. centaurus
    Posted 2 years ago #

    Thank you for your very quick response! :)

    I have the latest version, and I have no error messages, I've tested it on two sites hosted on 1and1 and it does the same thing ... : When I click "Authorize this facebook account" worpress it disconnects me and asked me my password wp-admin

    I tested two other known sites hosted by OVH, and then it works perfectly ... This is certainly a problem with 1and1 but I do not see that at all ...

  5. Efficient Scripts
    Plugin Author

    Posted 2 years ago #

    When authorizing fb accounts you have 2 steps. First one is to log in into your fb account (if not already) and authorize the app and then you're redirected to microblogposter's settings page.
    Do you successfully pass the first step? Log out from fb and retry.

    I guess you have the error when you're redirected to settings page.
    Also try disabling any other plugins and retry, maybe it's a conflict with some other plugin. Yeah it could be also some php function that is disabled on 1and1 and that is used when you're redirected.

  6. centaurus
    Posted 2 years ago #

    Yes steps work very well on OVH but not on 1and1 (I do not understand why)

    But I noticed a difference in the validation link: with 1and1! missing "www"

    I changed the link:

    To :

    With : http://www.top-du-web.com (not top-du-web.com )

    Like this, it me validate my Authorization (but it disconnects me wordpress just after) I did more than to reconnect and it works!

    I hope you'll understand the problem or just to set it in the next version ...

    Thank you again for this great plugin!

    PS : Sorry for my imperfect English, I hope you understand me ;)

  7. Efficient Scripts
    Plugin Author

    Posted 2 years ago #


Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic