Support » Plugin: WP CSV » discarting and rearranging columns seems to work fine

  • Resolved Odo_1


    first, thank you for this great plugin, it just works for me.

    In my research it stated in your FAQs to absolutely not changing the order of the columns or even deleting them.
    Because this would have been a bit of a problem for me I tried it anyway.
    I first exported the csv with your plugin. Then I began editing out most of the columns (except post_title and post_type), only leaving custom-field columns. I even rearranged some of the custom-field-columns in the way they make most sense to my clients, who who would like to enter their data into excel-tables and have it upload as content.
    The custom types and fields I created with the help of My-Content-Management-plugin.
    After filling this new template in my spreadsheet-programm and exporting it as a cvs-file I uploaded the file with wp-csv and it just worked fine. No hick-ups, all content was entered in the right places (custom-fields)…
    Now I am worried – is it supposed to work, or am I just lucky?

    Happy Holidays!!!

Viewing 1 replies (of 1 total)
  • Plugin Author CPK Web Solutions


    Hi Odo_1

    Happy holidays to you too!

    Yes, I’m not surprised it worked, but there are situations where it wouldn’t work. It’s a bit complicated, so I just say it isn’t officially supported. It saves me from getting angry emails from people! 🙂

    If you broke custom fields into two or more groups with other fields in between, then I wouldn’t expect it to work very well. The thumbnail field is expected at a certain place too.

    Anyway, it sounds like it’s working for you, so I see no reason not to use it that way. I think it should be ok. Just be cautious if you make further re-arrangements and don’t blame me if something unexpected happens! 🙂

    I intend to add in a feature in future to make it easier to re-arrange and rename fields.

    Best wishes


Viewing 1 replies (of 1 total)
  • The topic ‘discarting and rearranging columns seems to work fine’ is closed to new replies.