WordPress.org

Support

Support » Plugins and Hacks » WP Quadratum » [Resolved] Disappearing Map?

[Resolved] Disappearing Map?

  • Hi Greg,

    Using your plugin on my website and it appears to be fetching location data from Foursquare just fine, but for the last month or so has not been displaying any maps.

    This only appears to be a problem in Chrome (desktop and Android versions), as the map appears when I load my site in Firefox, IE, and the stock Android browser.

    I have tried disabling the few plugins I have installed in Chrome, but it doesn’t seem to make a difference; map still won’t load in that browser. Would appreciate hearing your thoughts.

    My details:

    * WP 3.5.2
    * Theme: Thesis 1.8.5 (paid) (also been working fine w/this theme for months; have made no changes to theme)
    * Running WPQ 1.2.0
    * Site is located here

    Thanks!

    http://wordpress.org/extend/plugins/wp-quadratum/

Viewing 15 replies - 1 through 15 (of 18 total)
  • PS – Using Chrome 27.0.1453.116 m (up to date); map still doesn’t load in Incognito mode w/all plugins disabled.

    Thanks!

    Plugin Author vicchi

    @vicchi

    Take a look in Chrome’s Developer Tools console (View menu -> Developer -> Javascript Console) …

    Are you seeing error messages along the lines of the following (the precise message may vary depending on the map type you have selected in the plugin’s settings) …

    Resource interpreted as Script but transferred with MIME type text/plain: "https://raw.github.com/vicchi/mxn/master/source/mxn.js?(openlayers)&ver=3.5.2". test.vicchi.org/:28

    Refused to execute script from 'https://raw.github.com/vicchi/mxn/master/source/mxn.js?(openlayers)&ver=3.5.2' because its MIME type ('text/plain') is not executable, and strict MIME type checking is enabled. test.vicchi.org/:1

    Uncaught ReferenceError: mxn is not defined

    … ?

    -Gary

    I got the second and third messages:

    Refused to execute script from ‘https://raw.github.com/vicchi/mxn/master/source/mxn.js?(googlev3)&ver=3.5.2’ because its MIME type (‘text/plain’) is not executable, and strict MIME type checking is enabled. http://www.damianbariexca.net/:1

    Uncaught ReferenceError: mxn is not defined http://www.damianbariexca.net/:130

    Plugin Author vicchi

    @vicchi

    Ah. That’s what I feared. This is a sort of bug. Chrome Canary introduced enforcing strict MIME type checking and this looks like it’s now been rolled into the production version of Chrome. Plus GitHub are now emitting content from raw.github.com astext/plain so while the underlying maps API script loads, Chrome is refusing to execute it.

    I’ll have to move Mapstraction (which is what the plugin is loading) to another location on GitHub and then modify the plugin to look in the new location. Which will mean a new version will have to be released.

    I’ll try and get this done this week.

    -Gary

    Right; thank you, Gary. I’ll keep an eye out for the update. Appreciate your attention to this!

    Plugin Author vicchi

    @vicchi

    A quick update … I’ve fixed this now, at least in my local development version. I hope to have a working version up on GitHub by the weekend, with emphasis on the word hope.

    There’s a couple of other things I need to do, like get the shortcode working properly again as well as cope with themes that use responsive layouts in a much better way, but this is significant progress. It’s just taken me a lot longer to do than I originally anticipated and has also opened a whole can of worms with the underlying mapping APIs, but that’s now been fixed.

    It shouldn’t be too much longer before I can push the next formal release to the Plugin Repository.

    -Gary

    Excellent, Gary; thanks very much! I appreciate your work on this.

    Plugin Author vicchi

    @vicchi

    So the (almost) beta version of v1.2.1 of the plugin is now on GitHub (https://github.com/vicchi/wp-quadratum/tree/v1.2.1-changes) and it’s working in-situ on my main blog (http://www.vicchi.org).

    Just got to update the plugin’s filters and revamp the documentation and we should be good to go.

    -Gary

    Hi Greg,

    Just checking in to see the status of v1.2.1. I appreciate your attention to the upgrade!

    –Damian

    Er, sorry Gary, not quite sure why I keep addressing you as ‘Greg’.

    Plugin Author vicchi

    @vicchi

    I’m on family vacation right now a d on the end of a roaming mobile data connection so I can’t do anything this week. All being well, should be able to release this next week on my return

    Great; thanks and enjoy!

    I have the same problem – the map is not visible in all browsers. I have catch the error in Chrome JS console:

    Uncaught ReferenceError: mxn is not defined

    on line:
    var map = new mxn.Mapstraction (id, 'openlayers');

    I have tried 1.2.0 and 1.2.1 versions without any effect.

    Solved. Installed theme did not have <?php wp_head(); ?> in header.php

    Not yet in Chrome because of:

    Refused to execute script from 'https://raw.github.com/vicchi/mxn/master/source/mxn.js?(googlev3)&ver=3.6' because its MIME type ('text/plain') is not executable, and strict MIME type checking is enabled.

    In other all is OK.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Resolved] Disappearing Map?’ is closed to new replies.
Skip to toolbar