Support » Fixing WordPress » Disappearing images in Media Library (again) in 3.4.2

Viewing 7 replies - 1 through 7 (of 7 total)
  • username required


    Note also this topic which suggest a problem with hosts, e.g. Godaddy, disabling thumb.php:

    Personally, I am experiencing this on more than one host although I do experience it on Godaddy.

    Checked permission and set them to files 644 and directories 755.

    username required


    Does anyone else have a problem with this ?

    Is it related to this topic?

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Please do not post topics about topics. That’s not really a good way to get support and will have volunteers like me scratching their head with “What..?”

    Obviously the images shouldn’t disappear but you need to narrow down the scope of what to look at to find the problem.

    I am experiencing it across a number of sites all upgraded to 3.4.2

    Focus on one site only and with that one site try the usual troubleshooting steps (thank you keesiemeijer for this):

    resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

    – switching to the default theme by renaming your current theme’s folder in wp-content/themes using FTP or whatever file management application your host provides.

    – re-saving your current permalink structure at Settings > Permalinks in your admin panel. WordPress will rebuild the .htaccess file. If WordPress cannot automatically edit the .htaccess file, it will provide manual instructions after saving.

    – re-uploading all files & folders – except – the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides. (manual upgrade)

    – re-running the upgrade via wp-admin/upgrade.php

    That’s a lot but hopefully can help you identify if it’s a hosting issue, plugin issue, or theme issue. I’m leaning towards a hosting issue but that’s a guess on my part.

    username required


    Thanks, but I was not “posting about posts”. I added the other post links to flag up what appears to be a common problem (… which does not get answered …) and I find it useful when others linked to related posts. It also pre-empts others from having to doing so to try, and be helpful.

    It could well be a host problem … but it is happening on more than one host and no server side changes made.

    The sites worked just fine before 3.4.2 and screwed up afterwards so something must have changed to break things. I hoped someone would know what it was. It would not be the first release to do so.

    I am getting the feeling 3.4.2 is a bad release.

    I guess no one knows does definitively then what causes this, or what fixes it, because that list of suggestions really just says, “… try everything”.

    I discovered that the issue for my site was that somehow WordPress had created a duplicate .htaccess file in the content folder. I opened it and it said “deny all.” I had also just updated the correct one by resaving the permalinks settings, so we had one functional .htaccess file and this extra one. Once I deleted the extra one, all my media images reappeared.

    I’m having similar problems.

    I have many WordPress sites in 3.4.1, with same configuration of plugins and hosting. One of them is in 3.4.2. Only this fails.

    When I upload a file, if I don’t press the “Save all changes” just after upload it, the file will not appear in the Gallery. But it is in the uploads directory, it has been uploaded correctly!

    Suppose we have an entry without attachments. Then we open the uploader popup, and upload one file (images, pdfs, no matter what). Now, we don’t press “Save all changes”; instead of that, we close the uploader popup window. We open again the popup and we see: Gallery [1]. So it knows there is one file. When we enter in the Gallery… it’s empty. There’s no file.

    Searching, we enter in Media Library (media.php) and here is our file. And it have correct info: url, parent post… everything is correct. So we return to the uploader popup of our entry and… nothing, we can’t see the file from here.

    I think that the problem is 3.4.2. I tried changing to other hosting, but it does not fix the problem. And I doubt that the problem are the plugins or the themes, because, as I said, I have many WordPress sites, with the same configuration, the same plugins, the same themes, the same hosting, all in 3.4.1, and only this one, in WordPress 3.4.2, fails.

    About the topics referenced in this one, I have checked the file permissions and the .htaccess file, and everything is correct.

    What could be the problem? Any suggestions?

    Thanks for reading!

    My issue has been fixed.
    I found, or rather my hosting provider found, that a cache plug-in had created a redirect to a new cache directory that it had created. Uninstalling the plug-in emptied removed the directory but did not remove the redirect.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Disappearing images in Media Library (again) in 3.4.2’ is closed to new replies.