Support » Fixing WordPress » Disallow comments on specific page

  • Resolved EzySetup

    (@ezysetup)


    I would like to disallow comment entry (or display) on a specific page. Apparently there used to be an “allow comments” box on the page edit screen, but I’m not finding anything in version 3.1. I’ve found and read older posts on the topic, but not anything recent.

    What would be the best way to disallow the entry and display of comments on a specific page (not post).

    Thank you in advance,
    Andrew

Viewing 6 replies - 1 through 6 (of 6 total)
  • ‘screen options’ tab near the top right of the page edit screen.

    Thank you, however this screen’s options only seem to control what is displayed on the ‘edit page’ in wp-admin. Hiding the comments area in the wp-admin area doesn’t seem to impact what my site’s visitors see.

    I want to disallow the entry or display of the comments section on the pages seen by my site’s visitors. How can this be done?

    ~Andrew

    in the ‘screen option’ dropdown field, there are tickboxes to show the ‘discussion’ box for the page;

    in the ‘discussion’ box below the page editor, you can then allow/disallow comments for the page.

    or do i understand something wrong?

    Ah, I see…

    In the screen options area, I chose to display the ‘discussions’ area. There I see the box where I can disable comments for the page.

    Thank you,
    Andrew

    Has this changed since that post? The Screen Options dropdown that I get only shows Author, Comments and Date. Checking or unchecking them only affects what is shown on the edit screen and has no effect on the page.
    This is driving me nuts – I have comment spaces on all pages and none on the posts: the reverse of what I want.
    Using Twentyeleven theme.

    esmi

    (@esmi)


    Forum Moderator


    Please post a new topic.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Disallow comments on specific page’ is closed to new replies.