Support » Plugin: ShortPixel Image Optimizer » Disabling Shortpixel CDN breaks the slider images

  • Resolved wellshot

    (@wellshot)


    Hi, I’m using SPIO and Autoptimize together. Initially I enabled SP CDN in Autoptimize. Then I installed SPOI to optimize the images locally and disabled the CDN in Autoptimize. After disabling CDN slider images are not appearing in GTmetrix (error: serve scaled images). When CDN is enabled, GTmetrix says “reduce image redirection”. As a matter of fact, I don’t want to use CDN due to latency issue. How to resolve this? I went through your documentation but couldn’t find answer.
    Also, in spite of following the instructions properly, I’m not able to see locally served webp images. (Webp using CDN is working fine). Please help.

    P.S.: Alex Florescu asked me to use SPAI, but I already mentioned that I don’t want to use CDN. I’m using SPIO so that it can serve webp locally and not ‘on the fly’ from any CDN. It’s not working.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Gerard Blanco

    (@sixaxis)

    Hi @wellshot,

    Could you please send us screenshots of all your ShortPixel settings, as well as your list of active plugins?

    Also please let us know exactly what slider we should pay attention to.

    One last thing, could you please specify what you mean by “breaks the slider images”?

    Thank you,

    Thread Starter wellshot

    (@wellshot)

    Hi @sixaxis,
    Thanks a lot for your response.
    I resolved the issue after a couple of hours of posting the topic. As my website is live one, so I kept exploring the web for possible solutions instead of waiting any response.

    I was using Autoptimize initially. I noticed it was using SP CDN to serve the webp images ‘on the fly’. My GTmetrix score was B(88) D(67) because of the image redirection issue. I didn’t want to use the CDN due to latency issue. So I installed SPIO and purchased 10k image credit. However, the GTmetrix score remained same. Then I disabled the SP CDN option from Autoptimize. I wanted to serve the optimized webp images from my website directly. The result was worse. The front page slider images were appearing blank, just white space (I’m using themegrill estore theme). GTmetrix score was unchanged, image redirect issue was gone, but new issue appeared: “Serve scaled images – image size 0x0 pixels in HTML and so on…”. I was confused, my images were already optimized by SPIO. I was also using WP Supercache. I deleted the optimized images, flushed out SP CDN, AO cache, WP SC cache and re-optimize the media gallery respectively. No change in result. Then I disabled AO and there was magic. Images started appearing normally again, GTmetrix score jumped to A(94) B(87). However, As I deactivated AO, I had to install WP-Optimize to minify the CSS, JS, HTML etc.

    Now almost all the issues have gone, I’m planning to upgrade/migrate to a better hosting plan in near future to improve the performance.

    Re. Autoptimize; there likely was specific JS that needed excluding, I’d be happy to help with that if you’d like to revisit 🙂

    Thread Starter wellshot

    (@wellshot)

    Hi @optimizingmatters,

    That would be very helpful of course. As a matter of fact I’m facing a different issue now.

    I’m using Woocommerce. The problem is when I’m adding a product from the homepage or the product page it gets added to cart alright, but when I’m clicking on ‘view cart’ for checkout, it shows ‘Your cart is empty’. I came to know about it when one of my customer complained me about the issue.

    When I checked it from my Desktop PC, I don’t see any problem, so is with my mobile phone. Then I checked from my friend’s phone (opened my website on my friend’s phone for the first time ever), and I can see the same issue.

    This causes my potential customers run away.

    Any help please?

    Would be best to start a different topic I guess, as unrelated to Shortpixel 🙂

    It seems Autoptimize is not active now, but I do see WP Super Cache AND WP Optimize (which might overlap), so disable one or both and see if the problem continues. Based on the outcome post a support topic in the appropriate forum?

    Thread Starter wellshot

    (@wellshot)

    @optimizingmatters,

    I have no issue regarding image optimization now. Autoptimize had to be disabled to resolve the image optimization issue.

    WP Super Cache and WP Optimize both are enabled. WP SC for cache and WPO for css/js/html minification.

    What can be the cause of the issue, any idea. I’m not sure, but I think it’s because of cache thing. I open my site from my PC/mobile frequently so, maybe my browser cache refreshes the data. But, as I opened my site from my friend’s mobile for the first time, maybe cache is not working properly. What do you think?

    it does sounds like a caching issue yes, hence my proposal to disable WPSC and/or WPO as a first step 🙂

    Thread Starter wellshot

    (@wellshot)

    Before I do this, can you check about the issue from your location? As I won’t be able to check it from my friend’s mobile now (it’s 11:55 PM, LOL).

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Disabling Shortpixel CDN breaks the slider images’ is closed to new replies.