WordPress.org

Forums

Disabling update notification features (core feature) (13 posts)

  1. jonez
    Member
    Posted 7 years ago #

    Why isn't there a simple preference to disable core and plugin update checks? Make it scary, make it horrible, but please make it available without adding to my plugin checklist.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    The issue was not raised until just before the release, leaving no time to get a simple checkbox option added.

    There is a ticket and patch in to do just that. These plugins are only there in order to combat irrational paranoia.

    Regardless, this information is not saved anywhere. It's only used to determine update needs.

  3. jonez
    Member
    Posted 7 years ago #

    Thanks for the update! I'm not terribly concerned about the privacy issues raised by some. I just don't need it active on every one of my WordPress installs ... seven and rising! :)

  4. war59312
    Member
    Posted 7 years ago #

    I see this:

    http://lud.icro.us/disable-wordpress-core-update/

    But not working at all:

    http://img206.imageshack.us/img206/7510/wordpressupdatebrokekn6.png

    I logged out of admin cp, cleared cache, and then relogin and check the plugin page and still showing updates.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    war59312: The update code sets a flag when it finds an update. So turning off the check like this won't disable that flag.

    So, it's not that it's looking for an update still, it's that it actually found one before you turned them off. The flag won't clear until you actually perform the update.

  6. war59312
    Member
    Posted 7 years ago #

    Oh ok, got ya.. Any way to remove that flag then?

  7. war59312: you're using the wrong plugin. Try this one: http://wordpress.org/extend/plugins/disable-wordpress-plugin-updates

    Ott042: the plugin does in fact hide the update notification even if the update flag has already been set before the plugin was activated :)

  8. war59312
    Member
    Posted 7 years ago #

    OMG I'm blind some times... Yeah thanks.. Got both working fine now... Thanks! :D

  9. _ck_
    Member
    Posted 7 years ago #

    I have found the "Disable Core Update" does not actually work in preventing all activity. The reason is because the default priority for the add_action is too low.

    edit the plugin and change the first line to this simple addition:
    add_action( 'init', create_function( '$a', "remove_action( 'init', 'wp_version_check' );" ),2);

    (only thing that is different is the ",2" which sets a very high priority)

    This change is tested working.

  10. localword
    Member
    Posted 7 years ago #

    Someone elsewhere posted a simple css fix so the wordpress core update message won't display (the chief concern I have for my customers).

    Edit the wp-admin.css (under the wp-admin directory) and add "display: none;" to #update-nag section. (it's near the very bottom)

    Worked like a champ and was very easy.

    The plug-in (http://wordpress.org/extend/plugins/disable-wordpress-plugin-updates/) oddly enough caused severe performance issues on my blogs causing page timeouts and extremely slow page loads. Deactivate the plugin, all is good, Activate it, performance issues abound. It would happen 1 out of every 4-6 page loads. Strange.

    Side note - I use A LOT of plugins, so this could be a result of a combination of plugins, not that this one is the sole cause. But wanted to provide a heads up if anyone else experienced the same thing.

  11. tommyk421
    Member
    Posted 6 years ago #

    @localword: Genius.

  12. alkagoel
    Member
    Posted 6 years ago #

  13. @alkagoel: Correct. What would you like done about it?

Topic Closed

This topic has been closed to new replies.

About this Topic