Support » Plugin: Nextend Social Login and Register (Facebook, Google, Twitter) » Disabling native username/password login and showing only social login buttons

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Laszlo

    (@laszloszalvak)

    Hi @aalaap!

    By default Nextend Social Login FREE places the buttons to the /wp-login.php page and to forms coming from the wp_login_form() function.
    So hiding these forms will make the Social Buttons not to appear.

    Actually I would also suggest using a plugin, that hides/disables the /wp-login.php page and then yes, you could simply publish the social buttons with one of our publishing methods:
    https://nextendweb.com/nextend-social-login-docs/documentation/#publish

    If you chose publishing the social buttons via shortcode, there are some parameters you can use, each can be seen here.
    https://nextendweb.com/nextend-social-login-docs/theme-developer/#shortcode

    Best regards,
    Laszlo.

    @laszlo Thanks for the quick response, but I have already perused those methods and I still have some concerns. I have updated my question with more information about the same.

    Plugin Support Laszlo

    (@laszloszalvak)

    Hi @aalaap!

    What you are looking for is the “OAuth redirect uri proxy page” at our Global Settings>General tab.

    So first you will need to create a new empty page, then you can select that page as OAuth redirect uri proxy page. In this way the login flow will be handled by that page and the URL of the Social buttons will have the slug of the page selected.

    Please note that, this will modify your redirect URI.
    So if you have any App setup, you will need to add the new redirect URI for each of your configured Apps.
    You will also receive a notification about it stating that:
    “Nextend Social Login detected that your login url changed.”
    by clicking the “Fix Error – Oauth Redirect URI” button you will see the steps you need to follow!

    Best regards,
    Laszlo.

    @laszlo This sounds more like it! I’ll try this out and let you know.

    I tried using a simple redirection plugin to redirect all wp-login.php requests to the social link, but that even redirects links to wp-admin (because it also redirects to wp-login.php internally) to the social links! 🙁

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disabling native username/password login and showing only social login buttons’ is closed to new replies.