Support » Plugin: Plugin Organizer » Disabling a single plugin on a single page

  • jdukelifestorypicturescom

    (@jdukelifestorypicturescom)


    Your FAQ says: “If you have a large number of plugins and don’t want them all to load for every page you can disable the unneeded plugins for each individual page”

    HOW????

Viewing 4 replies - 1 through 4 (of 4 total)
  • If you want to do this on a page-by-page basis it’s easy. Go to the Settings option. Then turn Selective Plugin Loading on.

    I use a blend of this, Custom Post Type Support and Fuzzy URL matching.

    Plugin Filters are great because you can set a path and then impact a page, or check a box so that all the children of said page inherit it’s plugin properties.

    I normally set up properties here for the home page path. Then I use Plugin Filters for other paths mainly keeping control of things all in one area.

    It’s the best plugin ever!

    Hey Jeff, one thing I noticed that’s a bit of an annoyance is when you choose Filter Groups, the sub-nav under Plugin Organizer disappears.

    jdukelifestorypicturescom

    (@jdukelifestorypicturescom)

    Jkirker,

    So, I turned Selective Plugin Loading on.

    Where do I select the page and the plugin to exclude (or include) from this page?

    Thanks.

    James.

    Now go into the page/post you want to tweak itself. You’ll see an option group which lists all of the installed plugins. From there simply turn them on or off.

    Also remember to set your global plugin config first.

    • This reply was modified 3 years, 10 months ago by .
    Plugin Author Jeff Sterup

    (@foomagoo)

    Thanks for helping this person out jkirker.

    “Hey Jeff, one thing I noticed that’s a bit of an annoyance is when you choose Filter Groups, the sub-nav under Plugin Organizer disappears.”

    This is a wordpress core thing. I have assigned that taxonomy to appear under the plugin organizer menu. That ability is built into the core. But when visiting the page for that taxonomy the sub menu it is assigned to disappears. I’ve been meaning to open a ticket with the wordpress developers about that. But haven’t gotten around to it. I may just not know the proper calls to make so it doesn’t disappear. I’ll try to get that done in the near future.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Disabling a single plugin on a single page’ is closed to new replies.