Support » Plugin: BackWPup - WordPress Backup Plugin » Disabling 2GB hard archive limit

  • Resolved cagsmith

    (@cagsmith)


    I’m not one to complain about a free, and admittedly fantastic plugin, but update 3.1.3 basically turns a fantastic plugin into something decidedly mediocre.

    Setting a hard 2GB archive limit? Really now? A lot of the sites I administer are less than this, but equally a lot of them are more. A lot of them are image heavy sites, which go back a long way. That soon adds up and setting this limit was inconvenient to say the least because suddenly I need to go and create additional, split backup jobs.

    And then today I encounter another problem. The 2014 uploads folder on one of the sites I administer is 3.3 gigs in size.

    We don’t have the level of granularity in the folder selection dialog to pick out “only” months 01-06, in order to make the files fit in the archive, nor do I particularly want to pick through 20 different tarballs to restore a site in case there is a serious issue.

    I know for a fact the server supports files of more than 2GB, since I just rolled back to version 3.1.2 and it worked fine.

    Can you please remove this hard 2GB limit? Why not just add a disclaimer instead saying “If your backup fails, try splitting it across multiple jobs” instead of implementing “baby mode”.

    https://wordpress.org/plugins/backwpup/

Viewing 8 replies - 16 through 23 (of 23 total)
  • Plugin Author Daniel Hüsken

    (@danielhuesken)

    In moment you can only do it with the beta version from github. That you can install by hand. in moment i can’t say when we release it.

    Hey,

    I have the same problem. I tried to revert to 3.1.2, but receive a handshake error from the Dropbox API.

    Which version is it exactly on github, I don’t seem to find it? Is it this one? It has been published before you replied to the questions in this forum so I thought that might be wrong.

    https://github.com/inpsyde/backwpup/releases/tag/3.1.3-beta8

    Thanks for your help!

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    I’m using 3.1.4 and I can’t find this option to disable the 2GB limit. Please advise.

    UPDATE: Ok, I found it in the git repository. I mistakenly thought the option had made it to the 3.1.4 release.

    Remco

    (@stifmeister1976)

    Thank you very much for the master.zip!
    Works like a charme without limitation of 2 gig.

    Hi
    I am currently using the the master plugin downloaded from the above link from Daniel.

    Seemed to be working but I am now encountering the error messages below

    job
    [INFO] BackWPup 3.2.0-beta1; A project of Inpsyde GmbH
    [INFO] BackWPup job: BackUpBackup
    [INFO] Logfile is: backwpup_log_232929_2015-07-23_12-11-49.html
    [INFO] Backup file is: backwpup_232929_2015-07-23_12-11-49.tar.gz
    [23-Jul-2015 12:11:49] 1. Try to backup database …
    [23-Jul-2015 12:11:49] Connected to database helenwar_wyg on localhost
    [23-Jul-2015 12:11:52] Added database dump “helenwar_wyg.sql” with 20.56 MB to backup file list
    [23-Jul-2015 12:11:52] Database backup done!
    [23-Jul-2015 12:11:53] 1. Trying to make a list of folders to back up …
    [23-Jul-2015 12:11:53] 425 folders to backup.
    [23-Jul-2015 12:11:53] 1. Trying to generate a file with installed plugin names …
    [23-Jul-2015 12:11:53] Added plugin list file “Helen-Warner-Photographer.pluginlist.2015-07-23.txt” with 2.21 kB to backup file list.
    [23-Jul-2015 12:11:53] 1. Trying to generate a manifest file …
    [23-Jul-2015 12:11:53] Added manifest.json file with 5.33 kB to backup file list.
    [23-Jul-2015 12:11:53] 1. Trying to create backup archive …
    [23-Jul-2015 12:11:53] Compressing files as TarGz. Please be patient, this may take a moment.
    [23-Jul-2015 14:11:59] Backup archive created.
    [23-Jul-2015 14:11:59] Archive size is 9.63 GB.
    [23-Jul-2015 14:11:59] 34244 Files with 10.28 GB in Archive.
    [23-Jul-2015 14:12:00] 1. Try to send backup file to Dropbox …
    [23-Jul-2015 14:12:00] Authenticated with Dropbox of user: Helen Warner
    [23-Jul-2015 14:12:00] Uploading to Dropbox …
    [23-Jul-2015 14:34:39] ERROR: Signal “SIGTERM” is sent to script!
    [23-Jul-2015 14:34:43] 2. Try to send backup file to Dropbox …
    [23-Jul-2015 14:34:44] Authenticated with Dropbox of user: Helen Warner
    [23-Jul-2015 14:34:44] Uploading to Dropbox …
    [23-Jul-2015 14:34:54] (400) False offset will corrected
    [23-Jul-2015 14:47:46] ERROR: Signal “SIGTERM” is sent to script!
    [23-Jul-2015 14:47:49] 3. Try to send backup file to Dropbox …
    [23-Jul-2015 14:47:50] Authenticated with Dropbox of user: Helen Warner
    [23-Jul-2015 14:47:50] Uploading to Dropbox …
    [23-Jul-2015 14:47:56] (400) False offset will corrected

    Any ideas please? Thanks
    Am currently running wordpress 3.8.8 (I know, I know – one reason why I am doing a back up so that I can update WP)

    Hi Helen,
    Try using the option “Don’t backup thumbnails from the site’s uploads folder”.
    This dramatically reduces file size.
    Maybe this can help.

    jenkisan

    (@jenkisan)

    ver 3.2rc (master file) worked like a charm and solved all issues with 2gb limit.

    tnx!

Viewing 8 replies - 16 through 23 (of 23 total)
  • The topic ‘Disabling 2GB hard archive limit’ is closed to new replies.