Support » Plugin: WooCommerce Products Per Page » Disables “persistent cart” in WooCommerce 3.2.0

  • Resolved Edith

    (@terragirl)


    In the latest WooCommerce version 3.2.0, this plugin disables the “persistent cart” information which is stored in the session in the database table “woocommerce_sessions”.

    When a customer logs out, the cart data is deleted from the session. When the customer logs back in, cart is empty.

    I’ve had to disable the plugin to get the persistent cart to work again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Jeroen Sormani

    (@sormano)

    Hi Edith,

    Thank you for reporting this, I was unaware of this behaviour.

    I’ve looked into this and I believe I found the solution to get this back and working nicely. I’d like to ask you to help test this out, if you can reach out to me through my site here I’ll send over the development version of the plugin.
    http://jeroensormani.com/contact

    Thank you,
    Jeroen Sormani

    Edith

    (@terragirl)

    Hi Jeroen,

    Thank you for the quick reply and fix! I can confirm that the code you’ve sent works perfectly. Awesome support!

    Best regards,
    Edith Karnitsch

    Hi. I don’t know if my problem is the same. But I have 2 advices at the top of wordpress and they are very annoying. They are:
    1. You need to install default WooCommerce page: Cart Page.
    2. You need to install default WooCommerce page: Checkout Page.
    I look into my php error log and find this:
    [21-Mar-2018 08:03:44 UTC] Advertencia de PHP: “carro” de desplazamiento de cadena ilegal en /home/debander/public_html/conunicornios.es/wp-content/plugins/woocommerce/includes/class-wc-cart- session.php en línea 80
    [21-Mar-2018 08:03:44 UTC] Advertencia de PHP: array_merge (): El argumento # 1 no es una matriz en /home/debander/public_html/conunicornios.es/wp-content/plugins/woocommerce/includes/class -wc-cart-session.php en línea 80
    I do not use my cart or my checkout page in my web. So I don’t understand WHY they are there. And they don’t have the “X” to close them. Just stay there all the time… hope anyone have a solution. Thanks!!
    Ps. I have update woocommerce today but they are still there. All my versions are updated. I use woozone, yoast seo and Viking guard. I usually use chrome. And I have 2 more webs with same configuration and they work just fine. I don’t understand…

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.